fndrumator pentru laborator 1. Tutorial de instalare si utilizare a mediului Eclipse

Introducere in dezvoltarea de programe in limbajul Java folosind Eclipse

1. Scopul lucrarii

Obiectivele acestei sesiuni de laborator sunt:

Instalarea si familiarizarea cu mediul de dezvoltare Eclipse si cu facilitatile oferite de acesta
Crearea, intelegerea si depanarea catorva aplicatii Java simple

Vizualizarea diagramei UML de clase a unei aplicatii Java

Crearea documentatiei unei aplicatii Java

Crearea si rularea unei aplicatii de sine statdtoare in Java (fisier executabil)

2. Instalarea mediului de dezvoltare Eclipse si a plugin-ului ObjectAid

Pentru a putea executa programe scrise in limbajul Java trebuie sd avefi instalat Java Runtime
Environment (JRE). Incepand cu versiuni mai noi, pachetul de instalare al mediului de dezvoltare Eclipse
contine deja si JRE. Instalati Eclipse (cu JRE) iar apoi eventualele extensii (plugin-uri) pentru acesta.
1. Descdrcati si instalati Eclipse cu JRE (este suficient sa alegeti in timpul instaldrii
Eclipse IDE for Java Developers) accesand site-ul: https://eclipse.org/downloads/
2. Instalati in Eclipse plugin-ul ObjectAid care va permite sd vizualizati diagrama de clase
corespunzatoare unui proiect Java astfel:
o descédrcati arhiva objectaid-1.2.4.zjp pusa la dispozitie
o modificati fisierul ecdljpse.ini (din directorul unde s-a instalat Eclipse) si adaugati la
argumentele masinii virtuale (vmargs) urmatoarele:
--add-opens=java.base/java.lang=ALL-UNNAMED
--add-opens=java.base/java.util=ALL-UNNAMED
--add-opens=java.base/java.text=ALL-UNNAMED
--add-opens=java.desktop/java.awt.font=ALL-UNNAMED
e deschideti Eclipse si instalati plugin-ul ObjectAid accesand meniul Help->Install New
Software... si apoi Add->Archive... urmand sa selectati objectaid-1.2.4.zjp, si apoi
urmati pasii simpli pentru a finaliza instalarea.
Pentru a va putea stoca proiectele personale intr-un singur loc si pentru a le putea regasi si folosi usor,
de fiecare datd cand porniti Eclipse, setati directorul personal de lucru accesand meniul File -> Switch
Workspace -> Other... si selectati directorul propriu de lucru.

3. Crearea unei aplicatii simple “Hello world”
3.1. Creati un proiect nou accesand meniul: File -> New -> Java Project

=
File | Edit Source Refactor MNavigate Search Project Run  Window Help

Mew Alt+Shift+N » ||( 2% Java Project ‘ =

COpen File... = Project... ‘
[, Open Projects from File System... B | Package

Recent Files 3 G Class

Close Ctrl+W & Interface

Close All Ctrl+Shift+W | &  Enum

Save Chrles @A Annotation

Save As... aﬁ Source Folder

Save All Ctrisshiftes | 159 JavaWorking Set

%
Revert [ Folder
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3.2. Dati un nume proiectului (Hello World), selectati directorul unde vreti sa-l salvati pe disc (este
recomandat sa lasati directorul de lucru curent selectat la pornirea Eclipse!), debifati (daca
existd) Create module-info.java file, apoi apasati butonul ,Finish”.

3.3. In proiectul creat, dati click dreapta pe pachetul src creat automat si creati o clasd noud, ca in

figura de mai ios:

File Edit Source Refactor Mavigate 5Search Project Bun Window Help
HufdEFEH RS LR R BA" RIE: W RSl K=1F R SRR S TR ACRCE S
[# Package Explorer 3 = 0
S|l
4122 HelloWorld
|» B JRE System Library [JavaSE-1.2]

[ src

| New ¥ 22 Java Project
Open in New Window T Project..
Open Type Hierarchy F4 | ¥ Package
Show In Alt+ShiftsW » | (& Class

Copy Chrl+C € Interface

5= Copy Qualified Name G Enum

Paste Gutey | E |Annatation

%  Delete Delete &9 Source Folder

3.4. Dati un nume clasei pe care o creati (numele claselor vor incepe intotdeauna cu majuscula!).
Puteti selecta optiunea de a crea automat metoda main - ce va fi executatd automat la rularea
programului:

Java Class
(1 The use of the default package is discouraged. @

Source folder: | HelleWorld/src | | Browse... |

Package: | | (default)

[JEnclosing type: Browse...

MName: minclass | I

Modifiers: (@) public (5 package private protected
[l abstract [ final static

Superclass: |java.|ang.0bject | | Browse... |

Interfaces: Add...

Remove

Which method stubs would you like to create?
public static void main(String[] ar@
[ Constructors from superclass
Inherited abstract methods

Do you want to add comments? (Configure templates and default value here

|:| Generate comments

Finish
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La apdsarea butonului Finish se va crea automat fisierul MainClass.java cu urmatorul cod sursa:

public class MainClass {
public static void main(String[] args) {

// TODO Auto-generated method stub
}

3.5. Vom scrie codul sursd care dorim sa se execute in metoda main. De exemplu, pentru afisarea
mesajului “Hello world”, vom scrie urmatoarea linie de cod:

System.out.println ("Hello world");

3.6. La rularea programului, rezultatul se afiseaza in consold, ca in figura alaturata:

File Edit Source Refactor Mavigate Search Project Run  Window Help
g - @ inif O Ui WG SIS P BETIHH G
[# Package Explorer &1 = [ MainClassjava 32
%| % public class MainClass {
4125 HelloWorld
> = JRE System Library [JavaSE-1.2]
4 [ src
4 f3 (default package)
1 [4] MainClass.java

public static void main(String[] args) {
System.out.println("Hello world");

" Problems @ Javadoc |8, Declaration B Console £3

<terminated> MainClass (1) [Java Application] C:\Program Files\Java'\jdk1.8.0_131\bin\javaw.exe
Hello world =i

4. Folosirea debugger-ului

Pentru a depana un program si a gdsi mai usor greselile, este recomandata folosirea debugger-ului.
Depanarea presupune pozitionarea de break point-uri in dreptul liniilor unde vrem s3 oprim executia
programului pentru a putea verifica valabilitatea valorilor din variabilele curente.

4.1. Activarea unui break pointin dreptul liniei unde vrem sa oprim executia programului se face

dand dublu click Tn dreptul acelei linii de cod, iar apoi rularea se face in modul Debug, ca in
figura de mai jos:

File Edit Source Refactor Mavigste Search Project Bun  Window Help

Tl @ i NiB-0-R-QA-F OSSP BE I H G
% Package Explorer & = 0 MainClass.java 2
ge Exp J
% * - 1 import java.util.Random;

4 (22 HelloWorld
1> B JRE System Library [JavaSE-1.8]
4 [P src
4 H (default package)
1+ ] MainClass.java

public class MainClass {

public statiec wvoid main(String[] args) {
int n = 10;
Random rand = new Random();
int i = rand.nextInt(n):;
int i2 = i*2;

[ T T R

System.out.println(i2);
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4.2. La rulare, executia se opreste in dreptul liniei unde am plasat break point-ul. Fereastra Variables
se deschide automat. Aici puteti vizualiza valorile variabilelor locale.

File Edit Source Refactor Mavigate Search Project Run  Window Help

o~ @RI EBNER SR E -0 RIS ST i flvm o
% Debug &2 | =08 [¥] MainClassjava £3 = O
a [T MainClass (1) [Java Application] 1 import java.util.Random;
a {2 MainClass at localhost: 11493 2
4 o Thread [main] (Suspended (breakpoint at line 9 in MainClass)) 3 puoblic class MainClass {

= MainClass.main(String[]) line: 9

v C\Program FilestJava\jdk1.8.0_131\bin'javaw.exe (Sep 21, 2018, 6:38:44 PM) public static void main(String[] args) {
int n = 10;
Random rand = new Random{);
int i = rand.nextInt(n);
int i2 = i*2;
System.out.println(i2);

()= Variables &2 ®=H ¥ = 0O

Name Value

G+ no method return value

@ args String[0] (id=18)
@ n 10
» @ rand Random (id=17}
o 5

4.3. In continuare aveti posibilitatea
- de a continua rularea programului (Resume F8),
- de a merge la urmatoarea linie de cod care se executa (Step Into F5); daca pe linia curentd
este apelul unei metode, atunci optiunea Step Into va intra in interiorul metodei.
- de a merge la urmatoarea linie de cod din metoda curenta (Step Over F6).

5. Crearea unei aplicatii Java pe baza unor fisiere sursa existente
Descarcati arhiva people.zip pusa la dispozitie. Aceasta contine clasele/fisierele Person.java,
Staff.java, Student.java, Database.java, MainClass.java si reprezintda un exemplu simplu de aplicatie
Java care gestioneaza personalul unei universitati. Dezarhivati si salvati fisierele intr-un director.
Creati un proiect nou Java numit People. Apoi importati in proiect toate fisierele .java salvate anterior
in acel director. Acest lucru este posibil accesand meniul File->Import->General->File System,

selectand directorul si toate fisierele .java

Deschideti clasa MainClass si executati aplicatia:
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File Edit Source Refactor Mavigate Search Project Run  Window Help
wlhe @ init O AU OSSP RE T FH R G D

[# Package Explorer &2 <:1:=:') | @ T = 08 [J] MainClassjava 52 | [J] Databasejava [4] Person.java [ Staff.java [9] Studentjava

"bJ People 19 fa=
1> B JRE System Library [JavaSE-1.8] * Main class of the Java application.
& [ src # It contains the main method that starts the Java application.

=/
public class MainClass {

4 f3 (default package)
[+ [4] Databasejava
1 [4] MainClassjava

[ m Person java S fr*
1[4 Staffjava * The main method.
*/

1+ [J Student,java . . . . .
= public static veoid main(String[] args) {

Student =1 = new Student ("Alex",1998, "UTICN20424");
Student =2 = new Student():
5taff x = new Staff("Andrei™,1990,"2Z03");

System.out.println(s2.getName());

=2 .setMName ("Andreea™) ;
=22.3etYearOfBirth (1997);

Database d = new Database();
d.addPerson (=1):

.addPerson (=s2);
.addPerson (x) :

L1istRAll ()

[T = Iy o1

6. Crearea diagramei de clase UML a unei aplicatii Java existente
Utilizarea plugin-ului ObjectAid

Pentru a genera diagrame de clase UML aferentda unei aplicatii Java, avand instalat plugin-ul
ObjectAid accesati meniul File->New->Other...->0bjectAid UML Diagram->ObjectAid Class Diagram.
Puteti selecta ceea ce doriti sa fie afisat pe diagrama UML.:

Create a new UML Class Diagram

Choose a folder and file name for the new UML class diagram. You
can also change the display and reverse engineering options for

Folder: | /People Browse...

Name: | UML Class Diagram

[]5ave Image with Diagram as

Classifiers

Show Attribute Default Show Visibility [| Show Stereotype
Show Operation Signature []Show lcons [ Show Package Name
Automatic Resize

Relationships

[V] Add Generalizations [¥] Add Nesting Show Association Multiplicity
Add Realizations Add Dependencies [ Show Association Labels

Add Associations Always Add Relationships

Attributes Operations

[+] Show Public  [¢] Show Package [+] Show Public  [¢] Show Package
Show Private Show Protected Show Private Show Protected
Show Static Show Static

< Back
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Pentru a se genera diagrama UML de clase selectati toate clasele care doriti sa apara pe diagrama si
tarati-le (drag and drop) in fereastra UML Class Diagram.ucls :

File Edit Source Refacter MNavigate Search Project Run  Window Help

M HR® NI E O R AW EGIEE S L Er D

t% Package Explorer 12 | B 5 | ¥ =0 B2, *UML Class Diagram.ucls 53
4122 People

> B JRE System Library [JavaSE-1.2]

4 [ src

4 i (default package)
[[J] Database javal

| [J] MainClass java|
| [ Personjava
>[4 Staff.java

+| |4 Student.java
& UML Class Diagram.ucls

Veti obtine diagrama UML de clase a aplicatiei in cadrul careia veti putea rearanja entitdtile si
legaturile dintre ele:

File Edit Mavigate Search Project Run Window Help

- @v‘@\*\yv@vi&v%v&?@vﬁb“’,v - v¥ - il W v
[# Package Explorer i [E \':_./ | ¥ = B [ MainClassjava [4] Databasejava [3] Person java [7] Staffjava [3] Studentjava 22 UML Class Diagram.ucls 51
= People
> B JRE System Library [JavaSE-1.8]
4 [ src
4 1 (default package) Person
> [ DEtIEbESE.Jﬂ.VE “name: String
- [J] MainClass.java _year0fBirth: int Database

> [4 Personjava
3 m Staff java

-persons: Arraylist<Person=

~Person(String,int)

. +setMame(String):void 0.t +Database()
 [4l Studentjava +getlame{):String +addPerson(Person):void
23 UML Class Dizgram.ucls +setyearOfBith(nt):void istal():void
+gefvear0fBirth(yint A
~toSiring()String
Student Staft
"SI String -room; String
~Sfudent() =)

~StaffiString,int, String)
+zetRoom(String:void
+getRoom():String
+toString():String

~Student(String,int, String)
+getStudentiDi):String ..
+toString():String .

MainClass

+MainClass()

+main(String[]):void

7. Crearea documentatiei unui proiect Java

Pentru a genera automat documentatia unui proiect Java accesati meniul Project->Generate
Javadoc... Setati apoi Javadoc command la fisierul javadoc.exe din pachetul JRE inclus in Eclipse. De
exemplu:
C:\Users\Admin\.p2\pool\plugins\org.eclipse.justj.openjdk.hotspot.jre.full.win32.x86_64_20.0.2.v202
30801-2057\jre\bin\javadoc.exe
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Selectati apoi toate fisierele cu cod sursa Java pentru care doriti s8 se genereze documentatie.
Acestea trebuie sa contind in prealabil tag-uri Javadoc /** ... */ al caror continut va aparea in
documentatia generatd. Specificati si locul unde se va genera documentatia (poate fi chiar un
subdirector docin cadrul directorului proiectului).

In urma generarii documentatiei rezults in principal o ierarhie de fisiere HTML. Pentru a vizualiza
documentatia generatd deschideti fisierul principal index.html:

File Edit MNavigate Search Project Run  Window Help

g~ Bie Q- Q- Q- @g~®™ 5~ - i =T - | c#
[ Package Explorer X E 8§ = O @ AlClEsses X
o
v 1= People =] o |fiIe:,a',a’,fD:,."Studenti,fPO02021_a'Lab,a'Peop|e,a'd0c,a'allclasses-indac.html

=\ JRE System Library [JavaSE-16]

M PACKAGE CLASS USE TREE INDEX HELP
v 3 (default package)

[J] Databasejava

[4] MainClass,java

Di Person,java

[l Staffjava All Classes
[4 Studentjava

C UML Class Diagram.mgc
Class Summary

w = doc
= class-use Class
= index-files o
[ resources Description
(= script-dir Database

@ allclasses-indesx.html
@ allpackages-index.html
& Database.html

A very simple database of people in a university.

i MainClass

|Z| element-list

@ help-doc.html Main class of the Java application.

& index.html

= B " Person

5 jquery-ui.overrides.css

@ MainClass.html A person class for a simple BlueJ demo program.
member-search-index js

[2] module-search-index js Staff

@ overview-treehtml

A class representing staff members for a simple BlueJ demo program.

m

18| package-search-index.js

@ package-summary.html Student
& package-tree.html
& package-usehtml
Person.html

A class representing students for a simple BlueJ demo program.

script.js

search.js

Staff.html
Student.html
stylesheet.css
tag-search-index.js

type-search-index.js

B ¢ o BEe

B

8. Crearea unei aplicatii de sine statatoare - un fisier JAR (Java ARchive)

Un fisier JAR (Java Archive) este o modalitate de impachetare a tuturor resurselor asociate unei aplicatii
Java (clase, imagini, etc.). Punerea acestora intr-un singur fisier JAR permite distribuirea lor ca un singur
fisier executabil sau nu, salvand astfel spatiu de stocare si simplificand procesul de descarcare. In cazul in
care fisierul JAR creat este executabil atunci aplicatia poate fi rulatéd avand la dispozitie doar acest fisier
JAR.
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Pentru a genera un fisier JAR executabil pentru un proiect Java accesati meniul File->Export->Java->
Runnable JAR file. Selectati clasa care contine metoda main si locul unde va fi salvat fisierul JAR, apoi

apasati butonul Finish:

= Runnable JAR File Expart

Runnable JAR File Specification

Launch configuration:
MainClass - People

Export destination:

Select a 'Java Application’ launch configuration to use to create a runnable JAR,

| Di\peoplejar

e Browse...

Library handling:
(@) Extract required libraries into generated JAR:

() Package required libraries into generated JAR

[ Save as ANT script

Di\StudentihPOO2023\Lab

'?\' < Back

() Copy required libraries into a sub-folder next to the generated JAR

Dacd doriti sa executati aplicatia utilizand fisierul JAR executabil creat, deschideti o consold in directorul
unde este localizat fisierul JAR si rulati comanda: java —jar nume_fisier.jar

Aplicatia va rula direct in cazul in care directorul din JRE care contine fisierul java.exe (de exemplu
C:\Users\Admin\.p2\poo|\p|ugins\org.eclipse.justj.openjdk.hotspot.jre.fuII.win32.x86_64_20.0.2.v20230§0
1-2057\jre\bin\java.exe) este deja inclus in variabila de sistem PATH a sistemului de operare Windows. In
caz contrar (foarte probabil) trebuie data calea completd catre java.exe in comanda prezentata mai sus.

Bl C:\Windows\System32\cmd.exe

Microsoft Windows [Version 10.0.19045.3448]
(c) Microsoft Corporation. All rights reserved.

d:\>c:\Users\Admin\.p2\pool\plugins\org.eclipse.justj.openjdk.hotspot.jre.full.
win32.x86_64 20.0.2.v20230801-2057\jre\bin\java.exe -jar people.jar

(unknown name)

Name: Alex

Year of birth: 1998
Student

Student ID: UTCN2@424

Name: Andreea
Year of birth: 1997

(unknown ID)
Name: Andrei
Year of birth: 1990

Staff member
Room: 209

d:\>
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9. Mersul lucrarii

9.1.

9.2.

9.3.

9.4,

9.5.
9.6.
9.7.

Pregatiti mediul de lucru pentru dezvoltarea de programe in limbajul Java urmarind pasii prezentati
in sectiunea 2 (daca nu este deja pregatit!). Creati-va propriul director in care va veti salva
proiectele si care va fi accesat de fiecare data cand porniti mediul de dezvoltare Eclipse (vezi
sectiunea 2).

Creati o aplicatie Java simpla care sa afiseze mesajul “Hello world” urméand pasii prezentati in
sectiunea 3.

Modificati metoda main a aplicatiei creata anterior astfel incat sa extrageti aleatoriu un numar
intreg intre 0 si 9 si tipariti dublul acestui numar (vezi figura din sectiunea 4). Depanati
programul realizat urmand pasii prezentati in sectiunea 4.

Creati aplicatia People prin importarea de fisiere Java existente (vezi sectiunea 5). Realizati o
vedere de ansamblu asupra codului sursa al aplicatiei si asupra rezultatelor furnizate in urma
executiei ei.

Generati si apoi analizati diagrama UML de clase aferentd aplicatiei People (vezi sectiunea 6).

Generati si apoi analizati documentatia aplicatiei People utilizdnd Javadoc (vezi sectiunea 7).

Creati o aplicatie de sine statdtoare (un fisier JAR executabil) pe baza proiectului People. Executati
intr-o consold fisierul JAR executabil creat (vezi sectiunea 8).
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