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UTILIZAREA EDITORULUI SCHEMATIC ECS

1. Scopul lucrării

Lucrarea urmăreşte familiarizarea cu editorul schematic ECS al sistemului CAD Xilinx
WebPACK, editarea şi implementarea unor circuite combinaţionale şi secvenţiale simple pentru placa
de dezvoltare XESS XSA-50.

2. Consideraţii teoretice

2.1. Componentele editorului schematic

Editorul schematic ECS (Engineering Capture System) al sistemului de proiectare Xilinx
WebPACK are două componente principale:

• Fereastra ECS. Aceasta este interfaţa principală pentru crearea şi editarea schemelor logice
ale sistemelor digitale sau componentelor proiectate.

• Programele pentru generarea listelor de conexiuni. Aceste programe translatează o schemă a
unui sistem digital sau a unei componente într-o listă de conexiuni care va fi utilizată în eta-
pele următoare de proiectare, pentru sinteza, simularea şi implementarea sistemului digital sau
a componentei. Lista de conexiuni va fi generată sub formă textuală, într-un limbaj de descri-
ere hardware (HDL). Acest limbaj poate fi VHDL sau Verilog, după fluxul de proiectare se-
lectat la crearea proiectului (XST VHDL, respectiv XST Verilog).

2.2. Utilizarea fişierelor sursă care conţin scheme

2.2.1. Crearea unui fişier pentru o schemă

Pentru crearea unui fişier sursă care va conţine o nouă schemă (fişier cu extensia .sch) se
procedează astfel:

1. Se deschide un proiect existent sau se creează un nou proiect (în modul descris în lucrarea Nr.
6, paragraful 2.4.3).

2. Se selectează comanda Project → New Source.

3. În fereastra de dialog New se selectează opţiunea Schematic.

4. În câmpul File Name se introduce numele fişierului care va conţine schema. Pentru adăugarea
automată a fişierului la proiect, se selectează opţiunea Add to Project, dacă această opţiune nu
este selectată.

5. Se selectează butonul Next.

6. În fereastra de dialog New Source Information, se selectează butonul Finish.

Editorul schematic ECS va fi lansat în execuţie într-o nouă fereastră (Figura 7.1).
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Figura 7.1. Fereastra editorului schematic ECS.

2.2.2. Deschiderea unui fişier care conţine o schemă

Pentru deschiderea unui fişier existent care conţine o schemă, în ecranul Project Navigator se
execută un clic dublu pe numele fişierului cu extensia .sch care conţine schema (fişier afişat în fe-
reastra Sources in Project).

2.2.3. Actualizarea fişierelor care conţin scheme

Atunci când se editează sau se actualizează un fişier care conţine simboluri, fişierele cu
scheme în care se utilizează simbolurile respective nu vor conţine ultimele versiuni ale simbolurilor.
De aceea, după modificarea simbolurilor utilizate în fişierele sursă care conţin scheme într-un proiect,
este necesară actualizarea acestor fişiere sursă.

Pentru actualizarea fişierelor sursă care conţin scheme se procedează astfel:

1. În fereastra Sources in Project din Project Navigator se execută un clic pe linia Device and
Design Flow.

2. În fereastra Processes for Current Source se execută un clic dublu pe linia Update all Sche-
matic Files.

Dacă se deschide o schemă cu editorul ECS conţinând simboluri care nu sunt actualizate (pe
baza datelor calendaristice ale fişierelor), se deschide o casetă de dialog care permite actualizarea
acestor simboluri. Pentru actualizarea tuturor fişierelor sursă care conţin scheme, se execută actualiza-
rea în ecranul Project Navigator.

2.3. Concepte de bază pentru utilizarea editorului schematic

O schemă creată cu editorul ECS este formată din următoarele elemente:
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• Simboluri;
• Conexiuni;
• Terminale de intrare/ieşire;
• Elemente grafice şi texte.

Aceste elemente sunt descrise în continuare.

2.3.1. Simboluri

Simbolurile sunt reprezentări grafice ale unor componente. Termenul simbol se referă de obi-
cei la un simbol electric, cum este o poartă, o componentă electrică sau un subcircuit. Cu ajutorul
editorului ECS pot fi create şi simboluri grafice (de exemplu, un bloc pentru definirea titlului sche-
mei), dar acestea nu au semnificaţie electrică. Fiecare simbol schematic este păstrat într-un fişier cu
extensia .sym, sau poate fi inclus într-o bibliotecă de componente, care este păstrată într-un fişier cu
extensia .lib.

Un simbol poate fi adăugat prin executarea comenzii Add → Symbol sau prin utilizarea buto-
nului Add Symbol . În zona din dreapta ecranului, în câmpul Categories se selectează categoria
simbolului, iar în câmpul Symbols se selectează simbolul care trebuie adăugat. Dacă se cunoaşte nu-
mele simbolului, se poate specifica un filtru pentru numele simbolurilor prin introducerea primelor
caractere din numele simbolului în câmpul Symbol Name Filter. Astfel se vor afişa doar simbolurile
ale căror nume încep cu caracterele respective (Figura 7.2). Se selectează apoi simbolul care trebuie
adăugat şi se plasează în cadrul schemei prin executarea unui clic în poziţia în care trebuie adăugat
simbolul.

Figura 7.2. Introducerea unui filtru pentru numele simbolurilor.

Atunci când se adaugă un simbol, editorul schematic atribuie în mod automat simbolului un
nume unic de forma XLXI_nn, unde nn este un număr întreg. Pentru modificarea acestui nume, se
poate utiliza comanda Add → Instance Name sau butonul Add Instance Name . Editorul nu per-
mite repetarea unui nume existent.

Proiectantul poate crea propriile simboluri prin gruparea unor părţi ale unei scheme (blocuri)
şi adăugarea unor terminale pentru semnalele de intrare şi cele de ieşire. Aceste simboluri (numite şi
macrouri) au un rol similar cu subprogramele (procedurile sau funcţiile) utilizate în limbajele de pro-
gramare. După crearea lor, simbolurile vor fi disponibile ca şi componente, similar cu componentele
din bibliotecile standard puse la dispoziţie de către sistemul de proiectare. Aceste simboluri pot fi uti-
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lizate ori de câte ori este necesar, fie în proiectul curent, fie în alte proiecte care vor fi elaborate ulte-
rior. Un alt avantaj al utilizării simbolurilor este că ele permit simplificarea construirii unor scheme
complexe, prin gruparea unor părţi ale schemei sub forma unor simboluri şi ascunderea detaliilor con-
structive ale părţilor respective. Aceste simboluri vor fi reprezentate în schema în care sunt plasate
sub forma unor dreptunghiuri, fiind indicate doar numele simbolurilor şi terminalele lor de intrare şi
de ieşire. Astfel este posibilă realizarea unor scheme complexe sub formă ierarhică.

Fiecare simbol poate conţine următoarele tipuri de informaţii:

• Reprezentarea grafică. Aceasta indică editorului ECS modul în care trebuie să apară simbolul
pe ecran. Această reprezentare nu are o semnificaţie electrică, indicând doar poziţia compo-
nentei respective în cadrul circuitului. Caracteristicile electrice ale simbolului sunt definite
prin atributele şi pinii acestuia.

• Texte. Textele au rolul de a eticheta simbolul, permiţând şi adăugarea unor informaţii supli-
mentare pentru descrierea simbolului. Similar reprezentării grafice, nici textele nu au o semni-
ficaţie electrică.

• Pini. Pinii asigură legătura electrică dintre un simbol şi firele de conexiune din cadrul sche-
mei. Dacă simbolul reprezintă o componentă, pinii simbolului terminalele fizice ale compo-
nentei la care se pot ataşa conexiuni electrice. Dacă simbolul reprezintă un bloc, pinii acestuia
reprezintă punctele de legătură la o conexiune internă a unităţii de proiectare reprezentată de
simbolul blocului. Un pin poate reprezenta fie un singur punct de conexiune (pentru un sem-
nal), fie puncte multiple de conexiune (pentru o magistrală).

• Atribute. Atributele descriu caracteristicile electrice ale unui simbol, componentele simbolu-
lui şi alte caracteristici ale acestuia. Un atribut are un nume şi o valoare. Fiecare simbol are un
număr de atribute predefinite care descriu numele simbolului, tipul acestuia şi alte caracteris-
tici care nu se modifică. După plasarea unui simbol într-o schemă, acestuia i se pot ataşa alte
atribute, iar acestor atribute li se pot atribui valori. Aceste atribute pot avea valori diferite
pentru fiecare copie a unui simbol.

2.3.2. Conexiuni

Conexiunile sunt linii electrice care conectează între ele pinii simbolurilor. Există două tipuri
de conexiuni:

• Conexiuni simple (scalare): fiecare din acestea reprezintă o singură conexiune electrică;
• Magistrale: acestea reprezintă conexiuni electrice multiple.

Magistralele se utilizează pentru gruparea unor semnale, cum sunt cele de date sau de adrese.
Magistralele sunt referite printr-un nume urmat de două cifre cuprinse în paranteze şi separate prin
caracterul ‘:’, de exemplu, DATA(15:0). Aceste cifre indică domeniul pentru numerele liniilor magis-
tralei. Se pot specifica linii individuale ale magistralei, de exemplu, DATA(0, 1, 7), sau linii individu-
ale şi grupe de linii, de exemplu, DATA(0, 1, 15:8).

Atât conexiunile simple, cât şi magistralele pot fi adăugate utilizând comanda Add → Wire

sau butonul Add Wire .
Pentru accesul la unele linii individuale ale unei magistrale se utilizează conectori de magis-

trală (“bus taps”). Un conector permite realizarea legăturii dintre o linie individuală a unei magistrale
şi un pin scalar al unui simbol. Conectorii permit de asemenea realizarea legăturii dintre linii multiple
ale unei magistrale şi un pin de magistrală al unui simbol, dacă numărul de linii interconectate este
acelaşi. Un conector de magistrală se poate adăuga prin executarea comenzii Add → Bus Tap sau uti-
lizarea butonului Add Bus Tap .

Fiecare conexiune are un nume, care reprezintă identificatorul acelei conexiuni pentru edito-
rul schematic şi pentru programele care generează listele de conexiuni. Numele se atribuie fie automat
de către editorul schematic, fie în mod explicit de către proiectant. Numele atribuit în mod implicit de
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către editor este de forma XLXN_n, unde n este un număr întreg. În mod normal, proiectantul va
redenumi toate conexiunile care reprezintă intrări sau ieşiri şi conexiunile interne pentru semnalele
care trebuie vizualizate în timpul simulării circuitului.

Adăugarea unui nume pentru o conexiune se poate realiza utilizând comanda Add → Net
Name sau butonul Add Net Name . Se va afişa o bară de opţiuni în partea din dreapta sus a ecra-
nului. Numele trebuie introdus în caseta liberă din această bară de opţiuni, în modul ilustrat în Figura
7.3 pentru conexiunea cu numele CLK. Se execută apoi un clic pe conexiunea căreia i se ataşează nu-
mele.

Figura 7.3. Bara de opţiuni pentru adăugarea numelui unei conexiuni.

Două sau mai multe conexiuni pot avea acelaşi nume. Între aceste conexiuni va exista o legă-
tură electrică, chiar dacă în schemă nu există o legătură fizică între ele.

2.3.3. Terminale de I/E

Terminalele de I/E sunt utilizate pentru marcarea conexiunilor pentru semnalele de intrare, de
ieşire sau a celor bidirecţionale din cadrul unei scheme. Dacă numele unei conexiuni apare de mai
multe ori într-o schemă, o singură copie a acestui nume trebuie marcată printr-un terminal de I/E.

Terminalele de I/E pot fi adăugate utilizând comanda Add → I/O Marker sau butonul Add I/O
Marker . În bara de opţiuni afişată în partea din dreapta sus a ecranului se selectează tipul termi-
nalului care trebuie adăugat: de intrare, de ieşire, sau bidirecţional (Figura 7.4).

Figura 7.4. Bara de opţiuni pentru specificarea tipului unui terminal de I/E.

În cazul în care o schemă are un simbol asociat, fiecare conexiune marcată printr-un terminal
de I/E trebuie să aibă un pin corespondent în simbolul schemei. Următoarele condiţii determină apari-
ţia unor erori atunci când se creează un model HDL al schemei:

• Simbolul schemei are un pin căruia i s-a atribuit un nume, dar schema nu conţine o conexiune
cu acelaşi nume.

• Schema are o conexiune cu numele corespunzător, dar conexiunea nu este marcată printr-un
terminal de I/E.

2.3.4. Elemente grafice şi texte

Deşi simbolurile, conexiunile şi terminalele de I/E sunt reprezentate prin elemente grafice
vizibile, acestea au şi o semnificaţie funcţională sau electrică. În această secţiune, elementele grafice
se referă la părţile grafice ale schemei care nu au o semnificaţie funcţională.

Într-o schemă se pot adăuga diferite elemente grafice auxiliare. Utilizarea cea mai obişnuită a
elementelor grafice este pentru crearea unui bloc cu titlul schemei. Acest bloc poate conţine şi alte
informaţii, de exemplu: numele şi adresa instituţiei sau companiei, numele proiectului, numele pro-
iectantului, data calendaristică, numărul versiunii şi a reviziei etc. Blocul de titlu se poate adăuga în
acelaşi fel ca şi un simbol, fiind disponibil ca un simbol cu numele tblock în categoria General din
biblioteca de simboluri. După adăugarea acestui simbol, se utilizează comanda Add → Text pentru
adăugarea textului în diferitele câmpuri ale blocului. Blocul de titlu este ilustrat în Figura 7.5. Pe lân-
gă acest bloc, în fiecare pagină se poate introduce un simbol care conţine titlul proiectului, numele
instituţiei şi a proiectantului, data calendaristică şi numărul paginii care conţine schema. Acest simbol
este disponibil cu numele title în categoria General din biblioteca de simboluri.
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Figura 7.5. Blocul de titlu tblock.

Pe lângă blocul de titlu, într-o schemă se pot adăuga şi următoarele elemente grafice: arcuri de
cerc, cercuri, linii şi dreptunghiuri. Aceste elemente se pot adăuga utilizând următoarele comenzi sau
butoane:

• Arcuri de cerc: comanda Add → Arc sau butonul Add Arc ;

• Cercuri: comanda Add → Circle sau butonul Add Circle ;

• Linii: comanda Add → Line sau butonul Add Line ;

• Dreptunghiuri: comanda Add → Rectangle sau butonul Add Rectangle .

Textele, similar elementelor grafice, pot furniza informaţii suplimentare despre o schemă sau
proiectul din care face parte schema. Textele pot fi plasate oriunde în cadrul unei scheme, chiar dacă
sunt suprapuse peste simboluri sau conexiuni.

Pentru adăugarea textelor se poate utiliza comanda Add → Text sau butonul Add Text . Se
va afişa o bară de opţiuni în partea din dreapta sus a ecranului, cu forma ilustrată în Figura 7.6. În
câmpul Text Value se introduce textul care trebuie adăugat, iar în câmpul Text Size se selectează di-
mensiunea dorită a textului.

Figura 7.6. Bara de opţiuni pentru adăugarea unui text.

2.4. Editarea şi utilizarea simbolurilor

Editorul schematic ECS se poate utiliza nu numai pentru editarea schemelor, ci şi pentru edi-
tarea simbolurilor. Simbolurile create de utilizator sunt adăugate în biblioteca locală de simboluri a
proiectului. Se pot utiliza şi modifica simbolurile existente în bibliotecile de componente ale siste-
mului de proiectare, după copierea lor în biblioteca locală de simboluri a proiectului. De asemenea, se
pot accesa bibliotecile de simboluri din alte proiecte pentru a utiliza simbolurile respective în proiec-
tul curent.

Toate bibliotecile şi simbolurile disponibile sunt listate în fereastra simbolurilor, care este
afişată în partea dreaptă a ferestrei editorului schematic, sau poate fi afişată prin utilizarea comenzii
Add → Symbol.

2.4.1. Tipuri de simboluri

Principalele simboluri sunt cele ale blocurilor (componentelor) utilizate pentru construirea
schemelor. De exemplu, majoritatea simbolurilor din bibliotecile puse la dispoziţie de sistemul de
proiectare WebPACK sunt simboluri de blocuri. Pe lângă aceste simboluri de blocuri, există diferite
simboluri grafice: tabele, texte explicative, dreptunghiuri, blocuri de titlu. Aceste simboluri grafice nu
sunt incluse în listele de conexiuni generate prin translatarea schemelor şi simbolurilor.

Toate simbolurile de blocuri sunt reprezentate sub forma unui dreptunghi căruia i se ataşează
la exterior pinii de intrare şi cei de ieşire. Pinii de intrare sunt plasaţi în partea stângă a dreptunghiu-
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lui, iar pinii de ieşire sunt plasaţi în partea dreaptă. În partea de sus a simbolurilor de blocuri se afi-
şează numele acestora, în modul ilustrat în Figura 7.7 pentru simbolul unui decodificator pentru afi-
şajul cu şapte segmente.

Figura 7.7. Modul de afişare a unui simbol de bloc.

2.4.2. Crearea unui nou simbol

Pentru crearea unui nou simbol se procedează astfel:

1. Se deschide o fereastră pentru un nou simbol prin comanda File → New, selectând opţiunea
Symbol.

2. Se selectează comanda Tools → Create Symbol. Se va deschide fereastra de dialog Create
Symbol.

3. În fereastra de dialog Create Symbol (Figura 7.8), se introduc numele pinilor (separaţi prin
virgule) în câmpurile Inputs (pentru semnalele de intrare), Outputs (pentru semnalele de ieşi-
re) şi Bidirection (pentru semnalele bidirecţionale). Se poate utiliza notaţia pentru o magis-
trală la introducerea numelui unui pin, de exemplu, D[3:0].

Figura 7.8. Fereastra de dialog Create Symbol.

4. Se execută un clic pe butonul OK. Editorul va crea şi va afişa simbolul.

5. Se salvează noul simbol, specificând numele fişierului pentru acest simbol. Numele fişierului
va deveni numele simbolului.

2.4.3. Modificarea unui simbol existent

Se pot modifica doar simbolurile care se află în directorul local al proiectului curent. Dacă se
doreşte modificarea unui simbol din bibliotecile puse la dispoziţie de sistemul de proiectare, se va
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deschide mai întâi o fereastră de dialog prin care se solicită confirmarea copierii simbolului în biblio-
teca locală din cadrul proiectului.

Pentru modificarea unui simbol aflat în directorul local al proiectului, se procedează astfel:

1. Într-o fereastră a editorului schematic, se selectează o copie a simbolului care trebuie modifi-
cat.

2. Se selectează comanda Edit → Symbol, sau se execută un clic cu butonul din dreapta pe copia
simbolului şi se selectează opţiunea Edit Symbol. Se va deschide o fereastră conţinând sim-
bolul selectat.

3. Se editează simbolul.

4. Se salvează simbolul modificat.

5. Se închide fereastra simbolului.

La revenirea în fereastra editorului schematic care conţine simbolul modificat, se va deschide
o fereastră de dialog pentru confirmarea actualizării simbolului din cadrul schemei.

2.4.4. Crearea unui simbol dintr-o schemă

Pentru crearea unui nou simbol reprezentând o schemă se procedează astfel:

1. În fereastra editorului ECS, se selectează comanda Tools → Create Symbol.

2. În fereastra de dialog Create Symbol, numele schemei va fi plasat în mod automat în câmpul
Name. Pinii care au fost creaţi în cadrul schemei sunt introduşi în mod automat în câmpurile
corespunzătoare (Inputs, Outputs şi Bidirection). Se execută un clic pe butonul OK.

Fişierul simbolului (cu extensia .sym) va fi creat şi va fi adăugat în biblioteca locală de sim-
boluri a proiectului.

2.4.5. Crearea unui simbol dintr-un fişier sursă HDL

Pentru crearea unui simbol schematic dintr-un fişier sursă HDL se procedează astfel:

1. În ecranul Project Navigator, se selectează modulul sursă HDL în fereastra Sources in
Project.

2. Se execută un clic dublu pe numele procesului Create Schematic Symbol în fereastra
Processes for Current Source.

Fişierul simbolului va fi creat şi va fi adăugat în biblioteca locală de simboluri a proiectului,
după care simbolul va putea fi plasat în cadrul schemei.

2.4.6. Utilizarea simbolurilor din alte proiecte

Este posibilă specificarea unei căi de căutare la directorul unui alt proiect pentru ca editorul
schematic să adauge simbolurile din acel proiect în fereastra de simboluri (Symbols). Simbolurile vor
fi disponibile numai pentru proiectele care utilizează acelaşi circuit programabil ca şi în proiectul în
care simbolurile au fost create.

Pentru adăugarea simbolurilor locale create într-un proiect în fereastra simbolurilor, astfel
încât aceste simboluri să fie accesibile în toate proiectele care vor fi implementate într-o anumită fa-
milie de circuite, se procedează astfel:

1. În fereastra editorului ECS, se selectează comanda Edit → Preferences. Se va deschide fe-
reastra de dialog Preferences.
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2. În pagina Device Families a ferestrei Preferences, se execută un clic pe semnul + de lângă
numele familiei de circuite pentru care se vor adăuga simbolurile (de exemplu, Spartan2).

3. Pentru familia de circuite selectată, se execută un clic pe linia Symbol Library Files and Paths
(Figura 7.9).

Figura 7.9. Fereastra de dialog Preferences.

4. Se execută un clic pe butonul Edit. Se va deschide o casetă de dialog pentru localizarea di-
rectoarelor şi fişierelor dorite.

5. În câmpul File or Path to Add, se introduce calea la proiectul ale cărui simboluri locale tre-
buie adăugate în fereastra Symbols a editorului ECS. Se poate utiliza butonul Browse
Directory sau Browse File şi caseta de dialog care apare pentru a selecta proiectul conţinând
simbolurile care trebuie puse la dispoziţie altor proiecte implementate în acelaşi tip de circuit.
Se execută apoi un clic pe butonul OK pentru a reveni la caseta de dialog precedentă. Calea
către proiectul selectat va apare în câmpul Path al casetei de dialog.

6. Se execută un clic pe butonul Add, iar apoi pe butonul OK pentru adăugarea căii specificate la
calea de căutare pentru toate proiectele care utilizează familia de circuite specificată.

La utilizarea simbolurilor din alte proiecte, se va utiliza comanda Save As pentru plasarea
simbolului în biblioteca locală a proiectului curent.

2.5. Recomandări pentru crearea schemelor

Fiecare schemă va fi translatată într-o listă de conexiuni sub forma unei descrieri în limbajul
VHDL sau Verilog. Această descriere va fi prelucrată apoi de sistemul de sinteză. Ţinând cont de
aceasta, este necesar să se respecte următoarele recomandări atunci când se creează schemele:

• Se vor utiliza numai primitive de I/E, nu şi macrouri de I/E. Exemple de primitive de I/E sunt
IBUF, OBUF, IFD, IFDX, OFD, OFDX. Macrourile sunt formate din mai multe primitive. Exemple
de macrouri de I/E sunt IBUF4 sau IFD_1. Dacă se utilizează asemenea macrouri, sistemul de
sinteză va insera un buffer IBUF sau OBUF la terminalul de intrare, respectiv de ieşire, ceea ce
va determina semnalarea unei erori în timpul procesului de implementare.

• Toţi pinii de intrare ai componentelor din biblioteca unificată Xilinx (Xilinx Unified Library)
trebuie conectaţi. În caz contrar, se vor semnala erori în cursul procesului de sinteză din cauza
discrepanţei dintre declaraţia componentelor şi utilizarea acestora.

• Nu se vor utiliza cuvinte cheie ale limbajelor de descriere ca nume de conexiuni sau de sim-
boluri.
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3. Desfăşurarea lucrării

3.1. Proiectaţi şi implementaţi cu porţi logice un decodificator pentru afişajul cu 7 segmente
al plăcii XESS XSA-50. Intrările decodificatorului vor fi 4 biţi reprezentând o cifră hexazecimală, biţi
notaţi cu H3, H2, H1 şi H0, H3 fiind bitul cel mai semnificativ. Ieşirile decodificatorului vor fi sem-
nalele a, b, c, d, e, f şi g pentru comanda celor 7 segmente ale afişajului (Figura 7.10). Pentru aprinde-
rea unui segment, semnalul care comandă segmentul respectiv trebuie să aibă valoarea logică 1.
Intrările H3, H2, H1, H0 ale decodificatorului vor fi conectate la liniile de date D3, D2, D1, respectiv
D0 ale portului paralel al calculatorului, iar ieşirile decodificatorului vor fi conectate la segmentele
afişajului cu 7 segmente ale plăcii XSA-50.

Figura 7.10. Notarea segmentelor afişajului cu 7 segmente.

Pentru realizarea decodificatorului, executaţi următoarele operaţii:

1. Desenaţi cele 16 cifre hexazecimale (0..9, A, b, C, d, E, F), în modul în care sunt reprezentate
de afişajul cu 7 segmente. Cifrele hexazecimale B şi D vor fi reprezentate sub forma literelor
mici corespunzătoare.

2. Întocmiţi diagramele Karnaugh pentru semnalele de ieşire a, b, c, d, e, f, g ale
decodificatorului în funcţie de semnalele de intrare H3, H2, H1 şi H0. Scrieţi ecuaţiile mini-
mizate ale fiecărui semnal de ieşire.

3. Lansaţi în execuţie programul WebPACK şi creaţi un nou proiect. Procedaţi în modul descris
în paragraful 2.4.3 din lucrarea Nr. 6. Numele proiectului poate fi, de exemplu, lab7_1.

4. Creaţi un nou fişier care va conţine schema decodificatorului. Procedaţi în modul descris în
paragraful 2.4.4 din lucrarea Nr. 6. Numele fişierului poate fi, de exemplu, dcd7seg1.

5. Editaţi schema decodificatorului utilizând porţile logice disponibile în categoria Logic din bi-
blioteca sistemului de proiectare WebPACK.

6. Adăugaţi buffere de intrare (ibuf) pentru semnalele de intrare şi buffere de ieşire (obuf) pen-
tru semnalele de ieşire. Conectaţi aceste buffere la semnalele de intrare şi la cele de ieşire ale
circuitului.

7. Ataşaţi numele semnalelor de intrare şi de ieşire, iar apoi adăugaţi porturi de intrare, respectiv
de ieşire la aceste semnale.

8. Verificaţi schema prin execuţia comenzii Tools → Check Schematic şi corectaţi erorile sem-
nalate.

9. Realizaţi asignarea pinilor la semnalele de intrare şi la cele de ieşire, procedând în modul des-
cris în paragraful 2.4.12 din lucrarea Nr. 6. Figura 7.11 ilustrează schema bloc a întregului
circuit şi pinii circuitului FPGA la care sunt conectate semnalele necesare. Salvaţi apoi sche-
ma finală.
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Figura 7.11. Conectarea portului paralel şi a afişajului cu 7 segmente la pinii circuitului FPGA de pe placa
XSA-50.

10. Reveniţi în fereastra Project Navigator şi realizaţi operaţiile descrise în paragraful 2.4.13 din
lucrarea Nr. 6 pentru sinteza şi implementarea proiectului.

11. Configuraţi circuitul FPGA în modul descris în paragraful 2.4.14 din lucrarea Nr. 6, utilizând
programul GXSLOAD. Observaţi cifra afişată de afişajul cu 7 segmente.

12. Pentru modificarea cifrei afişate şi verificarea decodificatorului, lansaţi în execuţie programul
GXSPORT. Acest program permite înscrierea unor valori în registrul de date al portului pa-
ralel al calculatorului, biţii D3, D2, D1 şi D0 ai acestui registru fiind conectaţi la intrările
decodificatorului proiectat. Fereastra programului GXSPORT este ilustrată în Figura 7.12.
Modificaţi valoarea unuia din biţii D3, D2, D1 sau D0 prin execuţia unui clic pe butonul co-
respunzător. Pentru transmiterea valorii modificate la portul paralel, executaţi un clic pe bu-
tonul Strobe. Verificaţi dacă cifra afişată corespunde cu valoarea binară corespunzătoare
biţilor D3, D2, D1 şi D0 din fereastra programului GXSPORT. Verificaţi apoi dacă se afişea-
ză corect fiecare din cele 16 cifre hexazecimale.

Figura 7.12. Fereastra programului GXSPORT.

Observaţie. La utilizarea programului GXSPORT, nu modificaţi valoarea bitului D7 din re-
gistrul de date al portului paralel. Acest bit este conectat la pinul circuitului FPGA prin care
se iniţiază secvenţa de configurare a circuitului în momentul în care pe acest pin se aplică
valoarea logică 0. Deci, bitul D7 trebuie să fie în permanenţă 1, deoarece în caz contrar confi-
guraţia circuitului FPGA va fi pierdută şi circuitul nu va mai funcţiona în mod corect.

3.2. Realizaţi proiectarea şi implementarea decodificatorului pentru afişajul cu 7 segmente
utilizând un decodificator 4:16 şi porţi logice. Pentru aceasta, executaţi următoarele operaţii:

1. Scrieţi semnalelor de ieşire a, b, c, d, e, f şi g ale decodificatorului pentru afişajul cu 7 seg-
mente sub formă de sume de produse, punând în evidenţă termenii produs necesari.

2. Desenaţi apoi pe hârtie schema circuitului, interconectând ieşirile decodificatorului 4:16 prin
porţi SAU.

3. Creaţi un nou proiect. Numele proiectului poate fi, de exemplu lab7_2.

4. Creaţi un nou fişier pentru schema circuitului proiectat. Numele fişierului poate fi, de exem-
plu, dcd7seg2.
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5. Editaţi schema decodificatorului pentru afişajul cu 7 segmente. Utilizaţi ca şi decodificator
4:16 componenta d4_16e, disponibilă în categoria Decoder. Intrarea E a acestui decodificator
permite validarea circuitului şi va fi conectată la 1 logic.

6. Executaţi apoi etapele 6-12 descrise la problema 3.1 pentru finalizarea schemei, implementa-
rea şi verificarea acesteia.

3.3. Deschideţi proiectul cu varianta a doua a decodificatorului pentru afişajul cu 7 segmente
(dcd7seg2). Un proiect de referinţă al acestui decodificator este disponibil în directorul
C:\Laborator\AC\proiecte\lab7_2. Editaţi schema decodificatorului pentru a efectua următoarele
modificări:

1. Eliminaţi atributul LOC al fiecărui semnal de intrare şi de ieşire, atribut care indică pinul la
care este conectat semnalul.

2. Ştergeţi bufferele de intrare IBUF şi cele de ieşire OBUF, fără să ştergeţi porturile de intrare
sau cele de ieşire.

3. Conectaţi între ele liniile care au fost întrerupte prin ştergerea bufferelor.

Salvaţi fişierul schemei sub un alt nume, de exemplu, dcd7seg.sch, într-un subdirector al di-
rectorului C:\Student.

3.4. Modificaţi schema numărătorului de 32 de biţi realizat în lucrarea Nr. 6, astfel încât nu-
mărătorul să fie utilizat pentru divizarea frecvenţei de ceas a plăcii XSA-50. Deschideţi mai întâi
proiectul care conţine schema numărătorului. Un proiect de referinţă al acestui numărător este dispo-
nibil în directorul C:\Laborator\AC\proiecte\lab6_1. Editaţi schema numărătorului pentru a efec-
tua următoarele modificări:

1. Ştergeţi legăturile la masă ale intrărilor de ştergere CLR ale celor două numărătoare de 16 biţi.

2. Conectaţi între ele terminalele CLR ale numărătoarelor, iar apoi prelungiţi legătura în stânga
şi sub semnalul de intrare CLK. Ataşaţi numele RST la această conexiune, iar apoi adăugaţi un
port de intrare. Semnalul RST va permite resetarea asincronă a numărătoarelor.

3. Ştergeţi porturile de ieşire S6 şi S0 ale circuitului, ca şi semnalele cu acelaşi nume. Ştergeţi
semnalul CNT(8) şi conectorul de magistrală din stânga acestuia. În acest moment, la magis-
trala CNT(15:0) trebuie să fie conectat doar semnalul CNT(9).

4. Adăugaţi în dreptul semnalului CNT(9) o componentă buf, disponibilă în categoria Buffer.
Conectaţi semnalul CNT(9) la acest buffer, prelungiţi în dreapta terminalul bufferului, ataşaţi
numele CLK_DIV la acest semnal şi adăugaţi un port de ieşire pentru semnalul CLK_DIV.

5. Eliminaţi atributul LOC al semnalului de ceas CLK.

Salvaţi fişierul schemei sub un alt nume, de exemplu, clkdiv.sch, într-un subdirector al di-
rectorului C:\Student.

3.5. Utilizând bistabile D, proiectaţi un numărător binar sincron de 4 biţi cu numărare în sens
direct (0, 1, 2, ..., 15, 0), prevăzut cu o intrare de ştergere asincronă. Pentru aceasta, executaţi urmă-
toarele operaţii:

1. Întocmiţi tabelul stărilor, desenaţi diagramele Karnaugh pentru intrările bistabilelor şi scrieţi
ecuaţiile minimizate ale acestor intrări.

2. Lansaţi în execuţie programul WebPACK şi creaţi un nou proiect (de exemplu, lab7_5).

3. Executaţi comanda Project → Add Copy of Source pentru a adăuga la proiect fişierul care
conţine schema divizorului de frecvenţă (clkdiv.sch), iar apoi fişierul care conţine schema
decodificatorului pentru afişajul cu 7 segmente (dcd7seg.sch).

4. Deschideţi fişierul clkdiv.sch şi în fereastra editorului schematic executaţi comanda Tools →
Create Symbol pentru a crea un simbol din schema divizorului de frecvenţă. Deschideţi apoi
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fişierul dcd7seg.sch şi creaţi un simbol din schema decodificatorului pentru afişajul cu 7
segmente.

5. În fereastra Project Navigator, creaţi un nou fişier pentru schema numărătorului proiectat.

6. Editaţi schema numărătorului utilizând bistabile fdc, disponibile în categoria Flip-Flop, şi
porţi adiţionale. Se pot utiliza porţi de forma and2b1, and3b1, and4b1, la care una din intrări
este complementată (deoarece nu sunt disponibile ieşirile complementate ale bistabilelor).

7. Adăugaţi la schema numărătorului simbolul divizorului de frecvenţă realizat pentru problema
3.4 (clkdiv). Acest simbol este disponibil în biblioteca locală de simboluri a proiectului. Co-
nectaţi semnalul de ieşire CLK_DIV al divizorului la intrările de ceas ale bistabilelor.

8. Prelungiţi la stânga terminalele CLK şi RST ale divizorului de frecvenţă, iar apoi conectaţi
semnalul RST la intrările CLR ale bistabilelor.

9. Adăugaţi un buffer de intrare ibuf urmat de un buffer bufg (disponibil în categoria Buffer)
pentru semnalul de ceas, iar apoi un buffer de intrare ibuf pentru semnalul RST. Conectaţi
aceste buffere.

10. Ataşaţi numele CLK, respectiv RST la semnalele de intrare ale divizorului de frecvenţă, iar
apoi adăugaţi porturi de intrare la aceste semnale.

11. Adăugaţi la schema numărătorului simbolul decodificatorului pentru afişajul cu 7 segmente
realizat pentru problema 3.3 (dcd7seg). Conectaţi ieşirile bistabilelor la intrările corespunză-
toare ale decodificatorului.

12. Prelungiţi la dreapta terminalele de ieşire ale decodificatorului şi adăugaţi buffere de ieşire
obuf pentru semnalele de ieşire. Ataşaţi numele a, b, c, d, e, f şi g la aceste semnale, iar apoi
adăugaţi porturi de ieşire la acestea.

13. Ataşaţi numele CLK_DIV la semnalul de la ieşirea divizorului de frecvenţă şi numele Q3, Q2,
Q1, Q0 la semnalele de ieşire ale bistabilelor.

14. Realizaţi asignarea pinilor la semnalele de intrare şi la cele de ieşire. Figura 7.13 ilustrează
schema bloc a întregului circuit şi pinii circuitului FPGA la care sunt conectate semnalele ne-
cesare.

Figura 7.13. Conectarea oscilatorului programabil, a portului paralel şi a afişajului cu 7 segmente la pinii
circuitului FPGA de pe placa XSA-50.

15. Salvaţi fişierul cu schema. Reveniţi în fereastra Project Navigator şi realizaţi implementarea
proiectului.

16. Configuraţi circuitul FPGA utilizând programul GXSLOAD.

17. Lansaţi în execuţie programul GXSPORT şi setaţi bitul D0 al portului paralel la 0. Observaţi
funcţionarea numărătorului, verificând dacă secvenţa de numărare este corectă.
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18. Resetaţi numărătorul prin setarea bitului D0 al portului paralel la 1. Verificaţi efectul resetării
asupra funcţionării numărătorului.

3.6. Adăugaţi o logică suplimentară numărătorului binar de 4 biţi proiectat la problema 3.5
pentru transformarea acestuia într-un numărător zecimal. Realizaţi resetarea numărătorului atunci
când acesta ajunge la valoarea 9 (1001). Implementaţi numărătorul şi verificaţi funcţionarea acestuia.

3.7. Implementaţi cu bistabile JK numărătorul binar sincron de 4 biţi din Lucrarea Nr. 4, figu-
ra 4.33. Desenaţi cu editorul ECS schema numărătorului, utilizând ca şi bistabil JK componenta fjkc
disponibilă la categoria Fip-Flop. Adăugaţi la această schemă divizorul de frecvenţă şi
decodificatorul pentru afişajul cu 7 segmente. Generaţi fişierul de configurare şi verificaţi funcţiona-
rea numărătorului. Determinaţi din rapoartele generate numărul de porţi echivalente al proiectului.
Pentru aceasta expandaţi lista proceselor executate pentru etapa de implementare (Implement Design)
şi executaţi un dublu clic pe linia Map Report pentru vizualizarea fişierului de raport. Comparaţi nu-
mărul de porţi echivalente cu numărul de porţi rezultate la implementarea aceluiaşi numărător cu
bistabile D (de la problema 3.5).

3.8. Utilizând bistabile D, proiectaţi un numărător binar sincron de 4 biţi cu numărare în sens
invers (15, 14, ..., 1, 0, 15), prevăzut cu o intrare de ştergere asincronă. După proiectarea numărăto-
rului, realizaţi operaţiile descrise la problema 3.5 pentru implementarea şi verificarea numărătorului.

3.9. Utilizând bistabile D, proiectaţi un numărător binar sincron de 4 biţi cu secvenţa de nu-
mărare corespunzătoare codului Gray (0, 1, 3, 2, ..., 12, 13, 15, 14), prevăzut cu o intrare de ştergere
asincronă. Implementaţi numărătorul şi verificaţi funcţionarea acestuia.

3.10. Proiectaţi un circuit pentru afişarea alternativă a celor două cifre hexazecimale repre-
zentând conţinutul liniilor de date ale portului paralel al calculatorului. Utilizaţi divizorul de frecvenţă
proiectat la problema 3.4 pentru comanda unui multiplexor care va transmite la intrările
decodificatorului pentru afişajul cu 7 segmente mai întâi biţii 7-4 ai registrului de date al portului pa-
ralel, iar apoi biţii 3-0 ai acestui registru. Executaţi următoarele operaţii:

1. Creaţi un nou proiect şi adăugaţi la proiect copiile fişierelor cu divizorul de frecvenţă
(clkdiv.sch) şi decodificatorul pentru afişajul cu 7 segmente (dcd7seg.sch). Utilizaţi comanda
Project → Add Copy of Source pentru adăugarea acestor fişiere din directorul proiectului
realizat pentru problema 3.5.

2. Deschideţi fişierele adăugate anterior şi creaţi simboluri din schemele conţinute de aceste fi-
şiere.

3. Creaţi un nou fişier pentru schema circuitului de afişare.

4. Plasaţi în schemă patru multiplexoare 2:1 (pe verticală). Utilizaţi ca şi multiplexor compo-
nenta m2_1 disponibilă în categoria Mux.

5. Adăugaţi în partea stângă a schemei 8 buffere de intrare (ibuf) şi trasaţi segmente de conexi-
uni la stânga acestora, care vor fi utilizate pentru conectarea liniilor de date ale portului para-
lel. Ataşaţi numele D7, D6, D5, D4, D3, D2, D1 şi D0 la aceste conexiuni, iar apoi adăugaţi
porturi de intrare la acestea.

6. Conectaţi la intrările D0 ale celor patru multiplexoare ieşirile bufferelor de pe liniile D7, D6,
D5, respectiv D4. Conectaţi apoi la intrările D1 ale multiplexoarelor ieşirile bufferelor de pe
liniile D3, D2, D1, respectiv D0.

7. Plasaţi în partea stângă a schemei simbolul divizorului de frecvenţă (clkdiv), iar în partea
dreaptă simbolul decodificatorului pentru afişajul cu 7 segmente (dcd7seg). Aceste simboluri
sunt disponibile în biblioteca locală de simboluri a proiectului.

8. Adăugaţi un buffer de intrare (ibuf) urmat de un buffer pentru ceas (bufg) la intrarea CLK a
divizorului de frecvenţă şi conectaţi aceste buffere. Adăugaţi un semnal CLK la intrarea
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bufferului ibuf  şi adăugaţi un port de intrare pentru acest semnal. Conectaţi la 0 logic intrarea
RST a divizorului de frecvenţă.

9. Conectaţi ieşirea CLK_DIV a divizorului de frecvenţă la intrările de selecţie S0 ale multiple-
xoarelor.

10. Conectaţi ieşirile multiplexoarelor la intrările H3, H2, H1, respectiv H0 ale componentei
dcd7seg.

11. Prelungiţi la dreapta terminalele de ieşire ale componentei dcd7seg şi adăugaţi buffere de ie-
şire obuf pentru semnalele de ieşire. Ataşaţi numele a, b, c, d, e, f şi g la aceste semnale, iar
apoi adăugaţi porturi de ieşire la acestea.

12. Ataşaţi numele CLK_DIV la semnalul de la ieşirea divizorului de frecvenţă şi numele H3, H2,
H1, H0 la semnalele de ieşire ale multiplexoarelor.

13. Realizaţi asignarea pinilor la semnalele de ieşire, conform figurii 7.13. Asignaţi pinul 88 la
semnalul de ceas CLK. Realizaţi asignarea pinilor la semnalele de intrare D0-D7 conform ta-
belului 7.1.

Tabelul 7.1. Conexiunile semnalelor de date ale portului paralel la pinii circuitului FPGA.

Semnal port paralel Pin FPGA

D0 50

D1 48

D2 42

D3 47

D4 65

D5 51

D6 58

D7 43

14. Salvaţi fişierul cu schema şi realizaţi implementarea circuitului.

15. Configuraţi circuitul FPGA utilizând programul GXSLOAD.

16. Lansaţi în execuţie programul GXSPORT şi setaţi biţii D6-D0 ai portului paralel la diferite
configuraţii, observând modul de afişare a valorilor respective. Nu modificaţi bitul D7 al
portului paralel (acest bit trebuie să fie în permanenţă 1).
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