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SIMULAREA FUNCŢIONALĂ A CIRCUITELOR CU SIMULATORUL
MODELSIM

1. Scopul lucrării

În această lucrare se prezintă principiul simulatoarelor şi al simulării funcţionale a circuitelor,
iar apoi se descriu programele disponibile în cadrul sistemului CAD Xilinx WebPACK pentru simula-
rea funcţională a circuitelor. Este prezentat programul HDL Bencher, care permite crearea unor ban-
curi de test necesare pentru simulare, şi simulatorul ModelSim, care permite simularea circuitelor
descrise prin scheme logice sau limbaje de descriere hardware.

2. Consideraţii teoretice

2.1. Simularea asistată de calculator

2.1.1. Principiul simulării asistate de calculator
Simularea unui circuit permite verificarea funcţionării circuitului pe baza descrierii acestuia

prin oricare din metodele uzuale (limbaje de descriere hardware, scheme, diagrame de stare), înainte
de implementarea efectivă a circuitului descris. Simularea asistată de calculator este metoda cea mai
utilizată pentru simularea circuitelor, utilizarea acestei metode devenind posibilă şi pentru sistemele
digitale complexe odată cu creşterea semnificativă a performanţei sistemelor de calcul moderne.
Această simulare se realizează cu ajutorul unui program simulator, care construieşte un model al cir-
cuitului pe baza descrierii acestuia de către proiectant, model care este echivalent cu o copie virtuală a
circuitului proiectat. Simulatorul execută apoi modelul circuitului şi analizează răspunsul acestuia la o
serie de combinaţii ale intrărilor aplicate circuitului într-un anumit interval de timp, o asemenea com-
binaţie fiind numită vector de test sau stimul.

Pe lângă vectorii de test, proiectantul poate specifica şi ieşirile aşteptate ale circuitului pentru
fiecare vector. În acest caz, simulatorul va compara ieşirile generate prin execuţia modelului cu cele
specificate de proiectant, care sunt cunoscute ca fiind corecte, afişând mesaje de eroare în cazul exis-
tenţei unor diferenţe între acestea. Dacă se detectează erori de funcţionare, descrierea circuitului poate
fi corectată mult mai simplu decât în cazul în care circuitul a fost implementat.

Pentru simularea sistematică a funcţionării unui circuit, de multe ori se creează un banc de
test (“testbench”) constând din circuitul care trebuie testat şi module adiţionale pentru generarea şi
aplicarea vectorilor de test la intrările circuitului testat. Vectorii de test pot fi reprezentaţi fie de toate
combinaţiile posibile ale intrărilor circuitului (dacă este posibil), fie de combinaţiile reprezentative
pentru toate situaţiile de funcţionare. Prin utilizarea bancurilor de test se simulează funcţionarea în
condiţii reale a circuitului, când acestuia i se aplică intrări din mediul exterior, de la un operator
uman, sau de la un alt circuit sau sistem digital.

Simularea asistată de calculator are următoarele avantaje principale:

• Simularea permite experimentarea cu diferite variante de proiectare ale circuitului şi condiţii
de funcţionare ale acestuia, fără a fi necesară implementarea acestor variante. Proiectantul va
putea implementa apoi varianta cea mai eficientă din punctul de vedere al performanţelor şi al
costului.
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• Prin utilizarea simulării asistate de calculator este posibilă testarea sistematică a circuitelor,
prin aplicarea unui număr mare de vectori de test la intrările circuitului, vectori care pot fi ge-
neraţi prin program sau pot fi specificaţi sub formă tabelară.

• Pentru circuite sau sisteme digitale complexe, simularea asigură reducerea costurilor şi redu-
cerea numărului erorilor de proiectare comparativ cu cazul în care se utilizează un prototip
hardware pentru testare. Realizarea unor circuite complexe cum sunt microprocesoarele mo-
derne nu ar fi fost posibilă fără utilizarea intensivă a simulării asistate de calculator.

2.1.2. Tipuri de simulare
Simularea poate fi executată în diferite etape ale procesului de proiectare şi poate utiliza dife-

rite nivele de abstractizare ale circuitului descris printr-o anumită metodă.
Simularea funcţională constă în simularea unei descrieri la nivel înalt a circuitului, această

descriere specificând funcţionarea circuitului, şi nu structura acestuia. Pentru descrierea circuitului se
pot utiliza diferite limbaje de modelare, cum sunt limbajele de programare. În acest caz, simularea
constă în compilarea şi execuţia modelului respectiv. În cele mai multe cazuri, simularea funcţională
se bazează pe un model al circuitului sub forma unei descrieri într-un limbaj de descriere hardware
(HDL).

Simularea logică reprezintă analiza funcţionării circuitului pe baza valorii unor variabile logi-
ce. Această simulare este numită şi simulare la nivelul transferurilor între registre (RTL – Register
Transfer Level), deoarece variabilele simulate sunt cele păstrate în registre. Simularea evaluează în
fiecare ciclu de ceas funcţiile logice ale căror valori sunt înscrise în registre.

Simularea la nivel de circuite se referă la analiza funcţionării unor modele ale circuitelor re-
prezentate prin interconectarea unor dispozitive electronice cum sunt tranzistoare, rezistenţe şi con-
densatoare. Această simulare constă în calcularea nivelelor de tensiune în funcţie de timp din toate
nodurile circuitului sau o parte a nodurilor. Aceasta presupune formularea şi rezolvarea unui mare
număr de ecuaţii diferenţiale, necesităţile de memorie şi de resurse de calcul fiind ridicate.

Simularea temporală constă în simularea funcţionării circuitului după determinarea întârzierii
reale a semnalelor pe diferitele căi de date. Această simulare se utilizează în special pentru circuitele
programabile, la care întârzierile semnalelor nu vor fi cunoscute decât în urma implementării circui-
tului, atunci când se poate determina numărul de conexiuni programabile utilizate pentru rutarea dife-
ritelor semnale. Informaţiile despre întârzierile semnalelor sunt furnizate simulatorului prin operaţia
numită adnotare inversă. Simularea temporală permite analiza funcţionării în condiţii reale a circui-
tului şi determinarea frecvenţei maxime de funcţionare a acestuia.

2.1.3. Funcţionarea unui simulator
Un program de simulare necesită două tipuri de intrări: un fişier cu descrierea circuitului care

trebuie simulat şi un set de stimuli care definesc toate semnalele de intrare pe durata timpului de si-
mulare. Circuitul poate fi descris printr-o listă de conexiuni sau printr-un limbaj de descriere hardwa-
re. În cazul în care circuitul este specificat prin scheme sau diagrame de stare, trebuie creată mai întâi
o descriere echivalentă a circuitului sub forma unei liste de conexiuni. Această descriere poate fi
într-un format specific listelor de conexiuni (de exemplu, EDIF – Electronic Design Interchange
Format), sau poate fi o descriere structurală a circuitului într-un limbaj de descriere hardware (de
exemplu, VHDL sau Verilog).

Proiectantul trebuie să specifice setul de stimuli care va fi aplicat la intrările circuitului pe
durata simulării acestuia. Opţional, proiectantul poate specifica şi semnalele de ieşire care trebuie ge-
nerate de circuit pentru fiecare stimul. Pentru definirea stimulilor, sistemele CAD sau simulatoarele
pun la dispoziţie diferite interfeţe, cele mai utilizate fiind interfeţele grafice, interfeţele bazate pe fişi-
ere text şi cele la nivelul liniei de comandă. Interfeţele grafice permit specificarea valorii semnalelor
aplicate la intrările circuitului sub forma unor diagrame de timp. Aceste interfeţe sunt utile atunci
când trebuie definit un număr redus de intrări. Atunci când există un număr mai mare de semnale de
intrare, sau trebuie definit un număr mare de tranziţii ale acestor semnale, este mai utilă specificarea
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într-un fişier text a unor comenzi care definesc valorile semnalelor de intrare şi momentele de timp în
care semnalele îşi modifică valoarea. Pot exista şi comenzi care specifică execuţia simulării pentru un
anumit timp. Introducerea comenzilor de simulare prin linia de comandă este utilă atunci când trebuie
modificată valoarea unor semnale care au fost definite anterior prin alte metode.

Simulatoarele utilizate în proiectarea asistată de calculator sunt simulatoare bazate pe eveni-
mente. Aceste simulatoare împart intervalul de timp pentru care se realizează simularea în intervale cu
durate foarte reduse, un asemenea interval fiind numit pasul simulării. Acest pas este exprimat
printr-un multiplu întreg al unei unităţi de timp care se numeşte limita de rezoluţie. Simulatorul nu
poate măsura intervale de timp mai reduse decât această limită. Limita de rezoluţie poate fi, de exem-
plu, de 1 picosecundă (ps), multiplul acesteia fiind specificat de proiectant. După trecerea unui in-
terval de timp egal cu pasul simulării, simulatorul determină toate semnalele ale căror valori au fost
modificate pe durata ultimului pas al simulării, o asemenea modificare fiind numită eveniment. Pentru
fiecare semnal de intrare care s-a modificat, simulatorul reevaluează modelul circuitului şi determină
noile valori ale semnalelor care sunt afectate de această modificare. Această reevaluare determină
modificarea altor semnale şi generarea altor evenimente.

Un semnal nu poate fi actualizat în acelaşi timp cu un alt semnal din care este generat, deoa-
rece semnalele nu îşi pot modifica valorile instantaneu. De aceea, modificarea valorii unui semnal este
planificată de simulator pentru un moment de timp ulterior faţă de timpul curent de simulare (tc), după
o întârziere numită întârziere delta (δ). Deci, modificarea valorii semnalului va fi executată la mo-
mentul de timp tc + δ.

La modificarea valorii unui semnal, se execută un ciclu delta în care se modifică valorile tutu-
ror semnalelor care depind de primul semnal. Dacă semnalele modificate afectează alte semnale, vor
fi planificate alte evenimente pentru timpul curent de simulare, la momentele de timp tc + 2δ, tc + 3δ, ...
La aceste momente vor fi executate alte cicluri delta pentru actualizarea valorii tuturor semnalelor.
Toate aceste cicluri delta se execută pentru acelaşi moment de simulare (tc), astfel încât timpul de si-
mulare nu avansează decât atunci când nu mai sunt alte evenimente planificate pentru timpul curent
de simulare şi toate semnalele au fost actualizate. Deci, întârzierea delta este de fapt o întârziere zero,
doar în mod conceptual fiind considerată ca o întârziere infinitezimală, fiind introdusă pentru a indica
succesiunea operaţiilor executate de simulator pentru actualizarea valorii semnalelor.

2.2. Generarea bancurilor de test cu programul HDL Bencher
Sistemul Xilinx WebPACK permite simularea funcţională a circuitelor proiectate cu ajutorul

simulatorului ModelSim, care poate fi lansat în execuţie din fereastra Project Navigator. Simularea se
realizează pe baza listei de conexiuni generate în etapa de sinteză, listă care este generată sub forma
unei descrieri structurale în limbajul VHDL sau Verilog. Sistemul permite şi simularea circuitelor
proiectate după etapele de translatare şi mapare, sau simularea temporală după etapele de plasare şi
rutare. În această lucrare este descrisă doar simularea funcţională.

Simularea funcţională se poate realiza fie utilizând un banc de test specificat sub forma unei
descrieri HDL, fie utilizând un banc de test generat în mod automat cu ajutorul programului HDL
Bencher. Acest program, care este integrat în sistemul Xilinx WebPACK, permite introducerea sub
formă grafică a stimulilor şi a semnalelor de ieşire aşteptate, generând în mod automat un banc de test
care poate fi utilizat cu simulatorul ModelSim. Deşi acest simulator permite specificarea stimulilor şi
prin comenzi introduse din linia de comandă, se recomandă ca înainte de lansarea simulatorului să se
creeze un fişier de stimuli, din care programul HDL Bencher va genera un banc de test.

2.2.1. Crearea unui fişier de stimuli
Pentru crearea unui fişier de stimuli cu ajutorul programului HDL Bencher, se procedează în

modul următor:

1. În fereastra Sources in Project din ecranul Project Navigator se selectează fişierul sursă con-
ţinând descrierea circuitului care trebuie simulat.
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2. Din meniul Project Navigator se selectează Project → New Source pentru crearea unui nou
fişier.

3. În fereastra de dialog New se selectează Test Bench Waveform ca tip al noului fişier.

4. Se introduce numele fişierului care va fi creat; acest nume trebuie să fie diferit de numele fişi-
erului sursă care va fi simulat.

5. Se selectează Next. În fereastra de dialog Select se va selecta fişierul sursă cu care trebuie
asociat fişierul de stimuli. În mod implicit, în această fereastră va apare selectat fişierul care a
fost selectat în fereastra Sources in Project (pasul 1).

6. Se selectează Next, iar apoi se selectează Finish. Va fi lansat în execuţie programul HDL
Bencher şi va apare fereastra Initialize Timing, care permite setarea unor parametri de timp
care vor fi utilizaţi în timpul simulării (Figura 8.1). În mod obişnuit, se pot păstra setările im-
plicite.

Figura 8.1. Fereastra Initialize Timing pentru setarea parametrilor de timp care vor fi utilizaţi la simulare.

Parametrii care pot fi setaţi depind de tipul circuitului care va fi simulat: secvenţial sau
combinaţional. Acest tip este determinat de programul HDL Bencher, iar setările implicite vor
fi selectate în mod automat; aceste setări pot fi modificate de utilizator. Unitatea de timp utili-
zată poate fi setată în caseta Time Scale. Pentru circuitele secvenţiale se poate seta frontul ac-
tiv al semnalului de ceas: frontul crescător (Rising Edge) sau frontul descrescător (Falling
Edge). Acest front este indicat printr-o săgeată în fereastra Preview. De asemenea, se poate
seta timpul cât semnalul de ceas va avea valoarea logică 1 (Clock high time) şi timpul cât
acest semnal va avea valoarea logică 0 (Clock low time). Aceste două intervale definesc pe-
rioada semnalului de ceas. Valoarea implicită a acestei perioade este de 100 ns, ceea ce cores-
punde unei frecvenţe de 10 MHz.

Parametrul Input setup time defineşte momentul de timp înainte de frontul activ al semnalului
de ceas când programul HDL Bencher setează valoarea semnalelor de intrare. Parametrul
Output valid delay defineşte întârzierea de la frontul activ al semnalului de ceas după care
programul HDL Bencher verifică valorile semnalelor de ieşire. Aceşti parametri reprezintă
constrângeri de temporizare, după implementarea circuitului fiind posibilă verificarea respec-
tării acestor constrângeri.

7. După setarea parametrilor de timp, se execută un clic pe butonul OK.
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În urma acestor operaţii, se vor afişa două ferestre principale ale programului HDL Bencher
(Figura 8.2). Fereastra de sus este cea a formelor de undă (Waveform), utilizată pentru vizualizarea
sau editarea formelor de undă ale stimulilor aplicaţi la intrările circuitului şi ale semnalelor de ieşire
aşteptate. În partea stângă a acestei ferestre se afişează toate semnalele cărora li s-au ataşat porturi de
intrare, de ieşire sau bidirecţionale. Direcţia portului este indicată grafic la dreapta numelui semnalu-
lui. În fereastra de jos se afişează conţinutul fişierului HDL cu care a fost asociat fişierul de stimuli.
De exemplu, în această fereastră se afişează lista de conexiuni care a fost generată dintr-o schemă, sub
forma unei descrieri VHDL.

Figura 8.2. Ferestrele principale ale programului HDL Bencher.

Programul HDL Bencher setează valoarea semnalelor de intrare şi verifică valorile semnalelor
de ieşire la momentele de timp setate în fereastra Initialize Timing. Această fereastră este afişată la
crearea unui nou fişier de stimuli, iar setările parametrilor de timp pot fi modificate ulterior prin co-
manda Options → Timing Constraints sau butonul Timing Constraints. Intervalul de timp în care
poate fi setată valoarea unui semnal de intrare este indicat prin culoarea albastru deschis, iar intervalul
de timp în care se verifică valoarea unui semnal de ieşire este indicat prin culoarea galbenă.

Dacă se poziţionează cursorul deasupra numelui unui semnal, se vor afişa într-o casetă atri-
butele semnalului respectiv. Dacă se poziţionează cursorul deasupra formei de undă a unui semnal, se
va afişa valoarea semnalului la momentul de timp respectiv. Prin poziţionarea cursorului pe linia care
indică timpul (implicit, prin diviziuni la fiecare 100 ns), se afişează valoarea timpului pentru poziţia
respectivă.

2.2.2. Iniţializarea semnalelor prin comutarea valorii biţilor
Pentru definirea stimulilor (vectorilor de test), trebuie să se iniţializeze semnalele de intrare.

Metoda cea mai simplă pentru iniţializarea semnalelor care sunt biţi este comutarea valorii acestora în
momentele de timp dorite. Pentru aceasta, se execută un clic pe forma de undă a semnalului în poziţia
corespunzătoare momentului de timp la care trebuie să se modifice valoarea acelui semnal. Valoarea
semnalului se va modifica din 0 în 1 sau din 1 în 0, iar această comutare se va produce la începutul
intervalului de timp precedent în care este permisă modificarea valorii semnalului. Acest interval este
indicat printr-o celulă de culoare albastră. Printr-o succesiune de comutări se pot defini în mod simplu
formele de undă ale semnalelor de intrare.
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În mod opţional, se pot iniţializa şi semnalele de ieşire cu valorile aşteptate ale acestora. Pen-
tru fiecare vector de intrare, se pot defini valorile corecte ale semnalelor de ieşire. Aceste valori se
definesc în mod similar cu valorile semnalelor de intrare, comutând valorile existente. Comutarea se
va produce la începutul intervalelor de timp indicate prin celule de culoare galbenă. În timpul simulă-
rii, simulatorul va compara valorile introduse de utilizator cu valorile generate la simulare. Simulato-
rul va afişa mesaje de eroare pentru fiecare moment de timp la care există o diferenţă între cele două
valori. Dacă nu se asignează valori semnalelor de ieşire, simulatorul nu va afişa mesaje de eroare.

2.2.3. Iniţializarea semnalelor prin metoda tabelară
Programul HDL Bencher permite introducerea rapidă a valorii semnalelor printr-o metodă

tabelară. Pentru aceasta se execută un clic dublu pe forma de undă a semnalului la momentul de timp
la care trebuie să se modifice valoarea acelui semnal. Se va deschide o casetă de editare, în care se
introduce valoarea semnalului la momentul respectiv (Figura 8.3). După introducerea valorii, se apasă
tasta Enter, iar caseta se va deplasa la dreapta, la următorul moment de timp la care se poate modifica
valoarea semnalului. Se continuă cu introducerea altor valori, după care se apasă tasta Esc. Se pot uti-
liza tastele cu săgeţi pentru deplasarea la un moment de timp următor sau precedent, sau la un alt
semnal.

Figura 8.3. Iniţializarea semnalelor prin metoda tabelară.

În cazul semnalelor care sunt vectori, valorile acestora se pot introduce în hexazecimal, zeci-
mal sau binar. Baza care va fi utilizată este cea utilizată şi pentru afişare, aceasta fiind indicată
printr-unul din butoanele “16 Display in Hex”, “10 Display in Decimal” sau “2 Display in Binary”. La
introducerea valorilor, se verifică dacă acestea se încadrează în domeniul admis, în funcţie de baza
selectată. Se pot introduce valori cuprinse între ghilimele duble, acestea fiind interpretate întotdeauna
ca valori binare, indiferent de baza selectată.

În caseta de editare deschisă la utilizarea metodei tabelare, se poate introduce o listă de valori
separate prin virgule. De exemplu, se pot introduce toate valorile corespunzătoare unui semnal, pentru
întregul interval de simulare. Dacă se introduc două virgule consecutive, se păstrează valoarea curentă
a semnalului. După introducerea unei liste, se apasă tasta Enter pentru memorarea valorilor, actuali-
zarea semnalului şi trecerea la semnalul următor. La terminarea editării, se apasă tasta Esc.

2.2.4. Iniţializarea semnalelor prin fereastra Pattern Wizard
Iniţializarea semnalelor cu o formă complexă este simplificată prin utilizarea ferestrei Pattern

Wizard. Pentru utilizarea acestei metode, se execută un clic dublu pe forma de undă a unui semnal,
prin care se va deschide aceeaşi casetă de editare ca şi la iniţializarea prin metoda tabelară. Se execută
un clic pe butonul Pattern (Figura 8.3), prin care se va deschide fereastra Pattern Wizard (Figura 8.4).

Opţiunile disponibile depind de tipul semnalului, aceste opţiuni fiind afişate în caseta Choose
Pattern. Pentru semnalele care sunt biţi, această fereastră permite generarea unei succesiuni de impul-
suri de o anumită lăţime, asignarea aleatoare a semnalelor sau comutarea valorii lor după un număr de
cicluri specificat. Pentru semnalele care sunt vectori, este posibilă în plus incrementarea sau decre-
mentarea valorii lor cu un anumit număr, sau deplasarea la stânga sau la dreapta a valorii lor după un
număr de cicluri specificat. Forma semnalului care va fi generat este afişată în partea de jos a feres-
trei.
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Figura 8.4. Fereastra Pattern Wizard.

2.2.5. Salvarea fişierului de stimuli
După editarea semnalelor de intrare şi, opţional, a celor de ieşire, se salvează fişierul cu forma

de undă a semnalelor prin comanda File → Save Waveform sau butonul Save Waveform. Poate apare o
fereastră de dialog pentru specificarea numărului unităţilor de timp care trebuie să treacă de la ultima
modificare a unui semnal de intrare până la terminarea simulării. Se poate selecta valoarea implicită
(1). Fişierul salvat va avea extensia .tbw şi va fi adăugat automat la proiectul curent deschis în fe-
reastra Project Navigator. Acest fişier poate fi deschis ulterior prin execuţia unui dublu clic pe nu-
mele acestuia în fereastra Sources in Project.

După salvarea fişierului de stimuli, programul HDL Bencher generează în mod automat un
fişier HDL care conţine bancul de test corespunzător fişierului salvat. Acest fişier poate fi vizualizat
în ecranul Project Navigator prin selectarea fişierului cu extensia .tbw în fereastra Sources in Project
şi execuţia unui clic dublu pe numele procesului View Behavioral Testbench din fereastra Processes
for Current Source.

2.3. Simularea funcţională cu simulatorul ModelSim
Simulatorul ModelSim (Model Technology) permite simularea funcţională a unui sistem digi-

tal înainte de implementarea acestuia pentru a verifica dacă funcţionarea este corectă. Simularea fun-
cţională poate fi executată pentru sisteme digitale specificate prin scheme sau prin limbaje de
descriere HDL. Sistemul ISE WebPACK permite lansarea în execuţie a simulatorului din fereastra
Project Navigator. Simulatorul poate fi lansat în execuţie şi separat, în afara sistemului ISE
WebPACK.

Pe lângă simularea funcţională, simulatorul ModelSim permite şi alte tipuri de simulare, care
pot fi executate în diferitele etape de implementare ale sistemului digital proiectat. Acestea nu sunt
descrise în lucrarea prezentă.

2.3.1. Lansarea în execuţie a simulatorului
După crearea unui fişier de stimuli cu programul HDL Bencher, poate fi lansat în execuţie

simulatorul ModelSim pentru simularea funcţională a proiectului. Sistemul ISE WebPACK realizează
toate operaţiile preliminare necesare înaintea execuţiei simulării: setarea proprietăţilor sesiunii de si-
mulare, crearea directorului de lucru, compilarea fişierelor sursă, crearea unui fişier de comenzi pen-
tru simulator (fişier cu extensia .fdo) şi iniţializarea simulării.

Pentru lansarea în execuţie a simulatorului ModelSim, se execută următoarele operaţii:
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1. În fereastra Sources in Project, se selectează fişierul de stimuli creat cu programul HDL
bencher (fişierul cu extensia .tbw).

2. În fereastra Processes for Current Source, se execută un clic pe semnul + din stânga liniei
ModelSim Simulator. Prin aceasta, se vor afişa procesele disponibile pentru fişierul de stimuli
(Figura 8.5).

3. Se execută un clic dublu pe linia Simulate Behavioral VHDL Model.

Figura 8.5. Vizualizarea operaţiilor care pot fi executate cu simulatorul ModelSim.

Se va lansa în execuţie simulatorul ModelSim, care va încărca bibliotecile necesare pentru si-
mularea diferitelor componente, va compila modelele funcţionale ale componentelor, va executa co-
menzile aflate în fişierul de comenzi creat de sistemul ISE WebPACK, după care va afişa mai multe
ferestre şi va opri procesul de simulare. În mod implicit, simulatorul va afişa fereastra principală a
acestuia, fereastra cu structura proiectului simulat, fereastra cu semnalele utilizate pentru simulare şi
fereastra cu formele de undă ale semnalelor de intrare şi a celor de ieşire obţinute prin simulare.
Aceste ferestre sunt prezentate în secţiunile următoare. Ferestrele afişate, ca şi alte opţiuni de simula-
re, se pot modifica din fereastra Processes for Current Source, executând un clic cu butonul din
dreapta pe linia Simulate Behavioral VHDL Model şi selectând Properties.

2.3.2. Fereastra principală a simulatorului
Fereastra principală a simulatorului ModelSim, în cazul în care simulatorul a fost lansat în

execuţie din sistemul ISE WebPACK, are forma din Figura 8.6.

Figura 8.6. Fereastra principală a simulatorului ModelSim.

Partea din stânga ferestrei principale este rezervată pentru un spaţiu de lucru. Acest spaţiu
permite accesul simplu la proiecte, unităţi de proiectare compilate şi date utilizate la simulare. Spaţiul
de lucru poate fi ascuns sau afişat prin comanda View → Hide/Show Workspace.

În partea din dreapta ferestrei principale se afişează comenzile care au fost executate de si-
mulator şi mesajele generate în urma execuţiei. Simulatorul afişează un prompter care permite intro-
ducerea unor comenzi în linia de comandă. Conţinutul acestei zone a ecranului este salvat în mod
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automat într-un fişier cu numele implicit transcript. Este posibilă salvarea acestui conţinut într-un
fişier cu un alt nume prin comanda File → Save Transcript As.

2.3.3. Fereastra Structure
Fereastra Structure permite vizualizarea sub formă ierarhică a structurii proiectului. Informa-

ţiile afişate în această fereastră sunt afişate şi în zona spaţiului de lucru din fereastra principală. Se
afişează toate unităţile de proiectare utilizate de simulator, cum sunt: bancul de test, unitatea testată
(etichetată cu uut – “unit under test”, pachetele utilizate în cadrul proiectului şi cele utilizate pentru
simulare. Această fereastră este utilă în cazul circuitelor complexe, atunci când se caută o anumită
componentă aflată la un nivel ierarhic inferior.

Prima linie din fereastra Structure indică unitatea de nivel superior din cadrul proiectului. În
cazul bancurilor de test create cu programul HDL Bencher, numele acestei unităţi este testbench. În
continuare se afişează unitatea testată şi pachetele utilizate. Structura unităţii testate poate fi vizuali-
zată prin expandarea ierarhiei acesteia, executând un clic pe semnul + din stânga numelui uut (Figura
8.7). Structura celorlalte componente poate fi expandată în mod similar.

Figura 8.7. Vizualizarea structurii unităţii testate în fereastra Structure.

În fereastra Structure se poate selecta o regiune, care va deveni regiunea curentă. Conţinutul
ferestrei semnalelor şi cel al ferestrei fişierului sursă este actualizat pentru a vizualiza informaţiile
pentru acea regiune.

2.3.4. Fereastra Signals
Această fereastră afişează numele şi valoarea curentă a semnalelor din regiunea selectată în

fereastra Structure. Fereastra Signals este împărţită în două zone. Zona din stânga indică numele sem-
nalelor din regiunea curentă (selectată în fereastra Structure). Zona din dreapta conţine valorile sem-
nalelor la sfârşitul simulării (Figura 8.8).

Prin execuţia unui clic dublu pe numele unui semnal se va selecta linia din fişierul sursă în
care este definit semnalul respectiv. Dacă fereastra fişierului sursă nu a fost deschisă în prealabil (cu
comanda View → Source), se va deschide în mod automat această fereastră. Se poate utiliza comanda
Edit → Sort pentru sortarea semnalelor în ordine ascendentă (Ascending), descendentă (Descending),
sau în ordinea declarării lor (Declaration Order).
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Figura 8.8. Vizualizarea semnalelor în fereastra Signals.

Adăugarea semnalelor în fereastra Wave
Fereastra Wave vizualizează sub formă grafică semnalele în timpul simulării (această fereastră

este descrisă în secţiunea 2.3.5). Sistemul ISE WebPACK specifică simulatorului ModelSim adăuga-
rea în fereastra Wave a tuturor semnalelor care sunt porturi de I/E. Pentru vizualizarea altor semnale,
este necesară adăugarea lor în fereastra Wave de către utilizator. Aceasta se poate realiza din fereastra
Signals.

Pentru adăugarea unor semnale în fereastra Wave, se procedează astfel:

1. În fereastra Structure, se expandează ierarhia unităţii testate până când se ajunge la compo-
nenta în care sunt definite semnalele dorite.

2. Se selectează această componentă în fereastra Structure. Conţinutul ferestrei Signals va fi ac-
tualizat pentru a afişa semnalele din regiunea selectată în fereastra Structure.

3. În fereastra Signals, se selectează semnalele care trebuie adăugate.

4. Se selectează comanda View → Wave → Selected Signals. Pentru adăugarea tuturor semnale-
lor din regiunea selectată în fereastra Structure, se poate selecta comanda View → Wave →
Signals in Region.

După adăugarea unor semnale în fereastra Wave, nu se trasează în mod automat forma de undă
a acestora. Pentru aceasta, este necesară fie executarea din nou a simulării, fie continuarea simulării.
Modul de execuţie al acestor operaţii este descris în secţiunea 2.3.5.

Forţarea valorii semnalelor
Comanda Edit → Force afişează o fereastră de dialog care permite aplicarea unor stimuli

semnalului selectat. Se pot selecta mai multe semnale pentru a forţa valoarea acestora. Fereastra
Force Selected Signal este ilustrată în Figura 8.9.
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Figura 8.9. Fereastra de dialog pentru forţarea valorii semnalelor.

Opţiunile pentru forţarea valorii semnalelor sunt următoarele:

• Value
Se afişează valoarea curentă a semnalului, care poate fi modificată prin introducerea unei noi
valori în acest câmp. În cazul unei magistrale, se poate specifica o valoare într-o bază diferită
de cea zecimală, sub forma bază#valoare. De exemplu, 16#0F specifică valoarea hexazeci-
mală 0Fh.

• Kind: Freeze
Semnalul este setat la valoarea specificată până când acesta este forţat din nou sau până când
semnalul este eliberat prin comanda Edit → NoForce.

• Kind: Drive
Se ataşează un driver semnalului, care va forţa semnalul la valoarea specificată până când
acesta este forţat din nou sau până când semnalul este eliberat prin comanda Edit → NoForce.

• Kind: Deposit
Semnalul este setat la valoarea specificată şi va rămâne la această valoare până la următoarea
tranzacţie a driverului, până când semnalul este forţat din nou, sau până când acesta este eli-
berat prin comanda Edit → NoForce.

• Delay For
Permite specificarea numărului unităţilor de timp pentru care trebuie aplicat stimulul. Acest
timp este măsurat de la timpul de simulare curent.

• Cancel After
Forţarea semnalului va fi terminată după timpul de simulare specificat prin această opţiune.

La selectarea butonului OK, se va lansa în execuţie o comandă force cu parametrii setaţi, co-
manda fiind afişată în fereastra principală. Dacă au fost selectate mai multe semnale, va apare următo-
rul semnal în fereastra de dialog. Pentru fiecare semnal pot fi setaţi parametrii diferiţi.

Setarea punctelor de întrerupere ale simulării
Se pot specifica puncte de întrerupere a execuţiei simulării (“breakpoints”), condiţiile în care

se va produce suspendarea simulării şi acţiunile pe care trebuie să le execute simulatorul atunci când
condiţiile specificate sunt îndeplinite. De exemplu, se poate specifica un punct de întrerupere atunci
când un semnal are o anumită valoare. La întâlnirea unui punct de întrerupere, se va afişa un mesaj în
fereastra principală, indicând semnalul care a determinat întreruperea.

Pentru accesul la comenzile care permit setarea punctelor de întrerupere pentru un semnal, se
selectează semnalul şi se execută un clic cu butonul din dreapta. Pentru setarea unui punct de întreru-
pere, se selectează opţiunea Add Breakpoint din meniu. Pentru eliminarea unui punct de întrerupere
setat anterior, se selectează opţiunea Remove Signal Breakpoint. Pentru eliminarea tuturor punctelor
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de întrerupere din regiunea curentă, se selectează opţiunea Remove All Signal Breakpoints. Pentru
afişarea listei punctelor de întrerupere care sunt setate, se selectează opţiunea Show Breakpoints.

Comanda Edit Breakpoint deschide fereastra de dialog Edit When (Figura 8.10). Prin setarea
opţiunilor din această fereastră, se va genera o comandă when, care va fi afişată în fereastra principa-
lă.

Figura 8.10. Fereastra de dialog pentru editarea punctelor de întrerupere.

Opţiunile din fereastra de dialog Edit When sunt următoarele:

• Condition
Permite specificarea condiţiei sau a condiţiilor în care se va produce suspendarea simulării şi
executarea comenzilor specificate prin opţiunea Command(s). O condiţie se poate specifica
sub forma unei expresii conţinând următorii operatori: egal (== sau =), diferit (!= sau /=), ŞI
logic (&& sau AND), SAU logic (|| sau OR). Operanzii pot fi nume de componente, nume de
semnale sau constante. De exemplu, egalitatea unui semnal scalar a cu o valoare se poate spe-
cifica sub forma a=1, iar egalitatea unui semnal vectorial num cu o valoare se poate specifica
sub forma num="1010". Operatorul de egalitate nu se poate utiliza pentru compararea valorii
a două semnale, ci numai pentru compararea valorii unui semnal cu o constantă. Ca şi condi-
ţie se poate specifica şi modificarea valorii unui semnal, sub forma a'EVENT.

• Opt. Label
Permite specificarea unei etichete opţionale pentru comanda when.

• Command(s)
Permite specificarea unei comenzi sau a mai multor comenzi care vor fi executate la îndepli-
nirea condiţiei sau condiţiilor setate. Implicit, se va executa o comandă echo, care afişează un
mesaj în fereastra principală, şi o comandă stop, care opreşte execuţia simulării. Execuţia
poate fi reluată ulterior.

2.3.5. Fereastra Wave
În fereastra Wave se vizualizează rezultatele simulării atât sub formă grafică, cât şi sub formă

numerică. Această fereastră este împărţită în mai multe zone (Figura 8.11). Zona din stânga conţine
numele semnalelor şi ierarhia componentei în care sunt generate. Este posibilă afişarea doar a numelui
semnalelor, fără ierarhia componentelor. În zona din mijloc se afişează valorile semnalelor din fe-
reastră. Valorile afişate se modifică în mod dinamic în funcţie de deplasarea cursorului în zona care
conţine forma semnalelor. Valorile se pot afişa în diferite baze de numeraţie. În zona din dreapta se
afişează formele de undă ale semnalelor. Formatul de afişare poate fi setat individual pentru fiecare
semnal. În această zonă se pot afişa un număr de până la 20 de cursoare.
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Figura 8.11. Fereastra Wave a simulatorului ModelSim.

Sub aceste trei zone se mai află alte trei zone, dintre care cea din stânga nu este utilizată. Zona
din mijloc indică timpul curent de simulare şi valoarea timpului corespunzătoare pentru fiecare cursor
setat. Valoarea corespunzătoare cursorului activ se afişează pe un fond alb. Se poate selecta un anumit
cursor prin selectarea valorii corespunzătoare acesteia în zona din mijloc. Zona din dreapta afişează
timpul absolut de simulare pentru fiecare cursor şi, în cazul existenţei mai multor cursoare, timpul
relativ între cursoare.

Gruparea semnalelor în fereastra Wave
Semnalele din fereastra Wave pot fi grupate în magistrale. O magistrală este o colecţie de

semnale concatenate într-o anumită ordine pentru a crea un nou semnal virtual. Un asemenea semnal
este util pentru afişarea mai compactă a acestuia atât sub formă grafică, cât şi sub formă numerică, sau
pentru setarea mai simplă a valorii acestuia comparativ cu setarea valorii semnalelor individuale. Un
semnal virtual este indicat printr-o icoană sub forma unui romb de culoare portocalie.

Figura 8.12. Fereastra de dialog pentru combinarea unor semnale într-o magistrală.

Pentru gruparea unor semnale, se selectează numele semnalelor în zona din stânga a ferestrei
Wave, după care se selectează comanda Edit → Combine. Va apare fereastra de dialog Combine
Selected Signals (Figura 8.12). În câmpul Name se introduce un nume pentru magistrala formată din
semnalele grupate. Se selectează apoi ordinea în care vor fi indexate semnalele în cadrul magistralei.
Dacă se selectează ordinea ascendentă (opţiunea Ascending), primul semnal selectat în fereastra Wave
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va avea indexul 0. Dacă se selectează ordinea descendentă (opţiunea Descending), primul semnal se-
lectat va avea indexul maxim. Dacă se doreşte eliminarea semnalelor selectate din fereastra Wave du-
pă combinarea lor, se activează opţiunea Remove selected signals after combining.

Formatarea afişării semnalelor în fereastra Wave
Există mai multe opţiuni pentru selectarea modului de afişare a semnalelor în fereastra Wave.

Acestea se pot aplica fie semnalelor individuale, fie mai multor semnale simultan. Principalele opţiuni
sunt descrise în continuare.

Pentru selectarea modului în care se afişează valoarea şi forma de undă a unui semnal, se se-
lectează numele semnalului, după care se selectează comanda Edit → Signal Properties. Această co-
mandă este disponibilă şi dacă se execută un clic cu butonul din dreapta pe numele semnalului
selectat, iar apoi se selectează opţiunea Signal Properties. Se va deschide fereastra Wave Signal
Properties, conţinând două grupe de opţiuni, View şi Format. Grupa de opţiuni View permite setarea
bazei de numeraţie în care se afişează valoarea semnalului (Radix), a culorii cu care se afişează forma
de undă a semnalului sau numele acestuia (Wave Color, respectiv Name Color). Setarea bazei de nu-
meraţie se poate realiza şi dacă se selectează numele semnalului, se execută un clic cu butonul din
dreapta, se selectează opţiunea Radix, iar apoi baza dorită.

Grupa de opţiuni Format permite setarea formatului de afişare al semnalului. Formatul Literal
afişează semnalul sub forma unor casete care conţin valorile semnalului respectiv (dacă există spaţiu
suficient). Formatul Logic afişează valori ale semnalului cum sunt 0 sau 1, ca şi unele valori speciale,
ca: U (valoare neiniţializată), X (valoare nedefinită), Z (valoare de înaltă impedanţă), - (valoare indi-
ferentă). În cazul selectării formatului Event, se marchează fiecare tranziţie a semnalului în timpul
simulării. Setarea formatului de afişare se poate realiza şi dacă se selectează numele semnalului, se
execută un clic cu butonul din dreapta, se selectează opţiunea Format, iar apoi formatul dorit.

Pentru selectarea modului în care se afişează numele unui semnal în partea din stânga feres-
trei Wave, se selectează numele semnalului, după care se selectează comanda Edit → Display
Properties. Această comandă este disponibilă şi dacă se execută un clic cu butonul din dreapta pe
numele semnalului selectat, iar apoi se selectează opţiunea Display Properties. Se va deschide fereas-
tra Wave Window Properties, în care modul de afişare poate fi setat în caseta Display Signal Path.
Valoarea 0 din această casetă va determina afişarea ierarhiei complete a componentei care generează
semnalul, de exemplu, /testbench/uut/clk_div. O valoare diferită de 0 indică numărul elementelor
ierarhice care vor fi afişate. Valoarea 1 va determina afişarea doar a numelui semnalului.

Salvarea rezultatelor simulării
Forma de undă a semnalelor, obţinută în urma simulării, este salvată în mod automat de si-

mulator într-un fişier cu formatul WLF (Wave Log Format), numele implicit al acestui fişier fiind
vsim.wlf. Acest fişier este plasat în directorul de lucru al simulatorului, care este acelaşi cu directorul
proiectului creat cu sistemul ISE WebPACK. În cazul în care acest fişier trebuie păstrat pentru vizua-
lizarea ulterioară, trebuie copiat într-un alt director sau trebuie redenumit, deoarece la o nouă simulare
conţinutul fişierului va fi rescris. Fişierul cu forma de undă a semnalelor poate fi deschis ulterior pen-
tru vizualizare şi compararea cu rezultatele unei simulări ulterioare. Pentru aceasta, în fereastra Wave
a simulatorului se execută comanda File → Open Dataset şi se selectează fişierul salvat anterior.

Simulatorul permite şi salvarea listei semnalelor din fereastra Wave, ceea ce este util atunci
când au fost adăugate semnale sau stimuli suplimentari în această fereastră, iar simularea trebuie exe-
cutată din nou. Lista completă a semnalelor va putea fi încărcată în mod simplu înaintea unei sesiuni
de simulare, fără a fi necesară adăugarea din nou a semnalelor. Pentru salvarea listei semnalelor, în
fereastra Wave a simulatorului se execută comanda File → Save Format. Lista este salvată într-un
fişier de comenzi (numit şi de macrouri), cu extensia .do. Numele implicit al fişierului este wave.do,
dar acest nume poate fi schimbat înainte de salvarea fişierului.
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Execuţia simulării
Atunci când simulatorul este lansat în execuţie din fereastra Project Navigator a sistemului

ISE WebPACK, se execută în mod automat simularea pentru întreaga perioadă de timp în care există
vectori de test definiţi. Dacă se adaugă însă noi semnale în fereastra Wave, forma de undă a acestora
nu va fi afişată în această fereastră, astfel încât va fi necesară executarea din nou a simulării. De ase-
menea, dacă se adaugă noi stimuli, poate fi necesară continuarea simulării. Pentru executarea acestor
operaţii şi a altor operaţii similare se pot utiliza butoanele sau comenzile descrise în Tabelul 8.1. Ma-
joritatea acestor butoane sunt disponibile atât în fereastra Wave, cât şi în fereastra principală a simu-
latorului. Opţiunile de meniu echivalente butoanelor sunt disponibile în fereastra principală.

Tabelul 8.1. Butoane şi opţiuni de meniu pentru execuţia simulării.

Buton Denumire Meniu echivalent Funcţie

Restart Run → Restart

Reîncarcă elementele proiectului şi resetează timpul
de simulare la zero, cu opţiunea de a păstra
formatarea curentă, punctele de întrerupere şi fişie-
rul WLF.

Run Length -- Specifică timpul pentru care se execută simularea
curentă.

Run Run → Run <timp implicit> Execută simularea curentă pentru timpul specificat
în caseta Run Length.

Continue Run Run → Continue Continuă execuţia simulării curente.

Run All Run → Run -all
Execută simularea curentă la infinit, sau până când
se întâlneşte un punct de întrerupere, sau până
când se apasă butonul Break.

Break -- Opreşte execuţia simulării curente.

2.4. Exemplu de simulare
Se prezintă în continuare etapele care trebuie executate pentru simularea schemei unui numă-

rător sincron de 4 biţi realizat cu bistabile JK, sensul de numărare fiind direct (de la 0000 la 1111).
Schema acestui numărător este prezentată în lucrarea de laborator Nr. 4, figura 4.33.

2.4.1. Crearea proiectului
Pentru crearea unui nou proiect şi adăugarea fişierului cu schema numărătorului, se execută

următoarele operaţii:

1. Se lansează în execuţie sistemul ISE WebPACK. În ecranul Project Navigator se selectează
File → New Project. Va apare fereastra de dialog New Project. În câmpul Project Location
din această fereastră se selectează directorul în care se va crea proiectul (un subdirector din
directorul C:\Student\). În câmpul Project Name se introduce numele proiectului. Se verifi-
că setările corecte în câmpurile Device Family şi Device (Spartan2, respectiv xc2s50-
5tq144). În câmpul Design Flow se selectează fluxul de proiectare XST VHDL. Se selectează
apoi butonul OK pentru a crea proiectul.

2. Se selectează comanda Project → Add Copy of Source pentru adăugarea fişierului cu schema
numărătorului. Acest fişier se găseşte în directorul C:\Laborator\AC\proiecte\lab8_1, nu-
mele fişierului fiind num4jk.sch.

3. În fereastra Sources in Project se execută un clic dublu pe numele fişierului num4jk.sch
pentru vizualizarea schemei numărătorului. Se închide apoi fereastra editorului schematic.
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2.4.2. Crearea unui fişier pentru bancul de test
Pentru crearea unui fişier care va conţine vectorii de test, fişier care va fi utilizat apoi pentru

crearea unui banc de test, se procedează astfel:

1. În fereastra Sources in Project se selectează fişierul sursă cu schema numărătorului.

2. Se selectează comanda Project → New Source pentru crearea unui nou fişier. În fereastra de
dialog New se selectează Test Bench Waveform ca tip al noului fişier. În câmpul File Name se
introduce numele fişierului care va fi creat, de exemplu, num4jk_tb (numele trebuie să fie di-
ferit de numele fişierului care conţine schema).

3. Se selectează Next, iar în fereastra de dialog Select se păstrează asocierea implicită cu fişierul
sursă care conţine schema numărătorului (num4jk).

4. Se selectează Next, iar apoi Finish. Prin aceste operaţii, se va lansa în execuţie programul
HDL Bencher şi va apare fereastra Initialize Timing.

5. În fereastra Initialize Timing, se setează parametrii de timp (aceşti parametri sunt descrişi în
paragraful 2.2.1). În mod implicit, frontul activ al semnalului de ceas este cel crescător
(Rising Edge) şi se păstrează această setare. Timpul cât semnalul de ceas are valoarea logică 1
(Clock high time) se setează la 5 ns, iar timpul cât semnalul de ceas are valoarea logică 0
(Clock low time) se setează de asemenea la 5 ns. Parametrii Input setup time şi Output valid
delay se setează la 1 ns. Se selectează apoi butonul OK. Vor apare cele două ferestre ale pro-
gramului HDL Bencher: fereastra formelor de undă ale stimulilor şi fereastra cu fişierul sursă
VHDL care a fost creat pe baza schemei circuitului.

2.4.3. Iniţializarea vectorilor de test
Semnalele de intrare ale numărătorului sunt CLK (semnalul de ceas) şi RST (semnalul de

resetare). Semnalul de ceas este iniţializat în mod automat conform parametrilor care au fost setaţi în
fereastra Initialize Timing, astfel încât este necesară doar iniţializarea semnalului RST. În plus, se vor
iniţializa şi semnalele de ieşire ale numărătorului cu valorile corecte (0000, 0001, 0010, ..., 1111),
valori care vor fi comparate cu cele obţinute la simularea circuitului, semnalându-se eventualele erori.

Pentru iniţializarea semnalelor RST, Q0, Q1, Q2 şi Q3, în fereastra programului HDL Bencher
care afişează formele de undă ale semnalelor se execută următoarele operaţii:

1. Pentru iniţializarea semnalului RST, se setează acest semnal la valoarea 1 la timpul de simula-
re 0 ns, iar apoi se setează semnalul la valoarea 0 la timpul de simulare 20 ns. Pentru aceasta,
se execută un clic în prima celulă albastră din dreptul semnalului RST (celulă marcată cu va-
loarea 0), iar apoi se execută un clic în a treia celulă albastră (cea corespunzătoare timpului de
simulare de 20 ns).

2. Se iniţializează mai întâi semnalele Q0, Q1, Q2 şi Q3 astfel încât acestea să fie 0 în primul ci-
clu de ceas. Pentru aceasta, se execută un clic cu butonul din dreapta în prima celulă galbenă
din dreptul semnalului Q0 şi se selectează opţiunea Set Value. În caseta Get Value se păstrea-
ză valoarea implicită 0 şi se execută un clic pe butonul OK. Se procedează similar pentru seta-
rea semnalelor Q1, Q2 şi Q3 la valoarea 0 în primul ciclu de ceas.

3. Pentru iniţializarea semnalului Q0 astfel încât valoarea acestuia să se modifice la fiecare im-
puls de ceas (începând cu al doilea ciclu), se va utiliza fereastra Pattern Wizard pentru co-
mutarea acestui semnal. Se execută mai întâi un clic dublu în a doua celulă galbenă din
dreptul semnalului Q0 (nu în prima celulă în care semnalul a fost setat la 0), iar apoi se exe-
cută un clic pe butonul Pattern. Prin aceasta se va deschide fereastra Pattern Wizard. În
această fereastră se setează următoarele opţiuni:

• Choose Pattern: Toggle
• Repeat pattern # times: 8
• Initial value: 0
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• Toggle every: 1

Se selectează apoi butonul OK.

4. Se procedează similar pentru iniţializarea semnalului Q1 astfel încât valoarea acestuia să se
modifice la fiecare două impulsuri de ceas începând cu al doilea ciclu. În fereastra Pattern
Wizard se modifică următoarele opţiuni:

• Repeat pattern # times: 4
• Toggle every: 2

Se selectează butonul OK.

5. Se procedează similar pentru iniţializarea semnalului Q2 astfel încât valoarea acestuia să se
modifice la fiecare patru impulsuri de ceas începând cu al doilea ciclu. În fereastra Pattern
Wizard se modifică următoarele opţiuni:

• Repeat pattern # times: 2
• Toggle every: 4

Se selectează butonul OK.

6. Pentru iniţializarea semnalului Q3 astfel încât valoarea acestuia să fie 0 în ciclurile de ceas 2-
9 şi 1 în ciclurile de ceas 10-17, se poate utiliza de asemenea fereastra Pattern Wizard, modi-
ficând următoarele opţiuni:

• Repeat pattern # times: 1
• Toggle every: 8

Se selectează butonul OK. În primele 17 cicluri de ceas, ieşirile Q3, Q2, Q1 şi Q0 ale numă-
rătorului trebuie să fie setate la valorile corespunzătoare combinaţiilor 0000, 0000, 0001,
0010, ..., 1111. Forma de undă a semnalelor trebuie să fie cea ilustrată în Figura 8.13.

Figura 8.13. Formele de undă obţinute prin iniţializarea semnalelor de intrare şi de ieşire.

7. Se salvează vectorii de test într-un fişier cu extensia .tbw utilizând comanda File → Save
Waveform sau butonul Save Waveform.

8. Se închide programul HDL Bencher utilizând comanda File → Exit.

2.4.4. Simularea funcţională

Pentru simularea funcţională a numărătorului, se procedează astfel:

1. În fereastra Sources in Project din ecranul Project Navigator se selectează fişierul cu extensia
.tbw care a fost creat anterior cu programul HDL Bencher.

2. În fereastra Processes for Current Source, se execută un clic pe semnul + din stânga liniei
ModelSim Simulator pentru afişarea proceselor disponibile.

3. Se execută un clic dublu pe linia Simulate Behavioral VHDL Model. Prin aceasta, se va lansa
în execuţie simulatorul ModelSim, care va executa simularea utilizând vectorii de test specifi-
caţi, va compara semnalele de ieşire aşteptate cu cele obţinute la simulare, iar apoi va afişa
rezultatele simulării în fereastra principală. Simulatorul va deschide de asemenea fereastra cu
structura proiectului, fereastra semnalelor şi fereastra cu forma de undă a semnalelor.
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4. Se examinează fereastra principală a simulatorului. Se observă afişarea unui mesaj indicând
faptul că au apărut erori la simulare (Figura 8.14).

Figura 8.14. Fereastra principală a simulatorului ModelSim afişând detectarea unor erori la simulare.

5. În fereastra Wave se execută un clic pe butonul Zoom Full  pentru vizualizarea formei de
undă complete a semnalelor.

6. Se grupează semnalele q0, q1, q2 şi q3 într-un semnal virtual şi se modifică formatul de afişa-
re al acestui semnal. Pentru aceasta, se execută următoarele operaţii:

• Se selectează comanda Edit → Sort şi se selectează opţiunea Descending. Semnalele
vor fi sortate în ordine inversă celei alfabetice.

• Se selectează semnalele q3, q2, q1 şi q0, iar apoi se selectează comanda Edit → Com-
bine. Se va deschide fereastra Combine Selected Signals. În câmpul Name: se introduce
numele semnalului virtual obţinut prin combinarea celor patru semnale, de exemplu, q,
se selectează opţiunea Descending, iar apoi se selectează butonul OK. Noul semnal va
fi afişat în fereastra Wave.

• Se selectează semnalul virtual creat, se execută un clic cu butonul din dreapta şi se se-
lectează opţiunea Radix, iar apoi Hexadecimal. Valoarea semnalului va fi afişată în he-
xazecimal.

7. În fereastra Wave se observă că secvenţa de numărare obţinută, indicată prin succesiunea va-
lorilor semnalului q, este 0, 1, 2, 3, 4, 5, E, F, 0, 1, 2, 3, 4, 5, E, F. Această secvenţă nu este
cea corectă.

8. Se salvează lista semnalelor din fereastra Wave, executând comanda File → Save Format. Se
păstrează numele implicit al fişierului (wave.do) şi se selectează butonul Save.

9. Se închide sesiunea de simulare prin închiderea ferestrei principale a simulatorului sau prin
execuţia comenzii File → Quit din fereastra principală.

2.4.5. Corectarea erorilor

Pentru corectarea erorilor din schema numărătorului, se revine în fereastra Project Navigator.
Se execută un clic dublu pe numele fişierului num4jk.sch pentru lansarea în execuţie a editorului
schematic şi se examinează schema numărătorului. Se poate observa că intrarea de sus a porţii ŞI din
dreapta este conectată la semnalul Q0, şi nu la ieşirea porţii ŞI din stânga.

Se selectează conexiunea eronată, iar apoi se şterg conexiunile selectate prin apăsarea tastei
Delete. Se refac conexiunile care au fost şterse şi se conectează în mod corect intrarea de sus a porţii
ŞI din dreapta. Se adaugă apoi conexiunea pentru semnalul Q0, se ataşează numele semnalului la
această conexiune şi se adaugă un port de ieşire pentru acest semnal.

Se salvează schema şi se închide fereastra editorului schematic.
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2.4.6. Reexecutarea simulării funcţionale
Se lansează din nou în execuţie simulatorul, executând un clic dublu pe linia Simulate

Behavioral VHDL Model. Se observă că în fereastra principală a simulatorului apare un mesaj indi-
când faptul că nu au fost detectate erori:

# ** Failure: Simulation successful (not a failure).  No problems detected.

În fereastra Wave, se selectează toate semnalele, iar apoi se şterg prin apăsarea tastei Delete
(cursorul trebuie să se afle în partea din stânga a ecranului). Se execută comanda File → Load For-
mat, se păstrează numele wave.do şi se selectează butonul Open. Astfel se va încărca lista semnalelor
care a fost salvată anterior, inclusiv formatul de afişare al acestora. Se observă că secvenţa de număra-
re este acum cea corectă.

Se închide sesiunea de simulare.

3. Desfăşurarea lucrării

3.1. Executaţi toate etapele descrise în secţiunea 2.4 pentru simularea funcţională a numărăto-
rului de 4 biţi realizat cu bistabile JK.

3.2. Întocmiţi tabelul de adevăr al unui multiplexor 4:1. Intrările de date ale multiplexorului
sunt D0, D1, D2, D3, intrările de selecţie sunt S1, S0, iar ieşirea este Z. Scrieţi ecuaţia ieşirii, desenaţi
schema multiplexorului cu editorul schematic, creaţi un banc de test cu programul HDL Bencher şi
simulaţi funcţionarea multiplexorului cu simulatorul ModelSim.

3.3. Scrieţi ecuaţiile ieşirilor unui decodificator 3:8. Intrările decodificatorului sunt A, B, C,
iar ieşirile sunt Y0, Y1, …, Y7. Desenaţi schema decodificatorului cu editorul schematic, creaţi un
banc de test cu programul HDL Bencher şi simulaţi funcţionarea decodificatorului cu simulatorul
ModelSim.

3.4. Utilizaţi un multiplexor 4:1 din biblioteca de componente a sistemului ISE WebPACK
(m4_1e) pentru implementarea următoarei funcţii booleene:

F (A, B, C) = Σ (0, 2, 4, 5)

Desenaţi schema circuitului cu editorul schematic, conectând intrarea de validare E la 1 logic.
Creaţi un banc de test cu programul HDL Bencher şi simulaţi funcţionarea circuitului cu simulatorul
ModelSim.

3.5. Implementaţi prin porţi logice codificatorul prioritar cu 4 intrări definit prin tabelul de
adevăr de mai jos (Tabelul 8.2).

Tabelul 8.2. Tabelul de adevăr al unui codificator prioritar cu 4 intrări.

Intrări Ieşiri
EI   I3  I2  I1  I0 Y1  Y0 GS EO

0   X   X   X   X 0    0 0 0

1   0   0   0   0 0    0 0 1

1   0   0   0   1 0    0 1 0

1   0   0   1   X 0    1 1 0

1   0   1   X   X 1    0 1 0

1   1   X   X   X 1    1 1 0

Intrarea EI este utilizată pentru validarea circuitului, iar I3, I2, I1, I0 sunt intrările de date. Y1
şi Y0 sunt ieşirile de date, la care se obţine codul intrării activate. În cazul în care sunt activate mai
multe intrări simultan, la ieşire se obţine codul intrării celei mai prioritare. Intrarea I3 este cea mai
prioritară, iar I0 este cea mai puţin prioritară. De exemplu, dacă intrarea I3 este 1, codul de la ieşire
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este 11, indiferent de valorile celorlalte intrări. Dacă circuitul nu este validat (EI = 0), ieşirile sunt
inactive (0 logic). Ieşirea GS este activată dacă cel puţin una din intrările de date este activată, iar ieşi-
rea EO este activată atunci când nici una din intrările de date nu este activată.

Întocmiţi diagramele Karnaugh pentru ieşirile codificatorului în funcţie de intrările de date I3,
I2, I1, I0, scrieţi ecuaţiile minimizate ale ieşirilor, iar apoi modificaţi ecuaţiile pentru a ţine cont de
intrarea de validare EI. Desenaţi schema circuitului cu editorul schematic, creaţi un banc de test cu
programul HDL Bencher şi simulaţi funcţionarea circuitului cu simulatorul ModelSim.

3.6. Simulaţi funcţionarea circuitului pentru detectarea secvenţei de intrare 1010 din lucrarea
de laborator Nr. 4 (problema 3.3). Desenaţi schema circuitului, creaţi un banc de test, iar apoi simulaţi
funcţionarea.

3.7. Simulaţi funcţionarea numărătorului cu secvenţa de numărare 0, 1, 2, 4, 5, 6, 0 din lucra-
rea de laborator Nr. 4 (problema 3.7). Desenaţi schema numărătorului utilizând bistabile JK, creaţi un
banc de test, iar apoi simulaţi funcţionarea.
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