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SISTEMUL DE DEZVOLTARE 
 TMS320VC5416 DSK 

 
1. Prezentare generală  
 

TMS320VC5416 DSK este un sistem de dezvoltare de sine stătător. Permite evaluatorilor să 
examineze diferite caracteristici ale procesoarelor de semnal C5416, pentru a observa dacă îndeplinesc 
cerinţele aplicaţiei lor. Modulul este o platformă excelentă pentru a dezvolta şi a rula programe pentru 
procesoarele digitale din familia TMS320VC5416. 
 

O schemă simplificată a plăcii VC5416 DSK este prezentată în figura 1: 

 
 

Figura 1.  Placa TMS320VC5416 DSK 
 

Sistemul are următoarele caracteristici: 
 - 64k cuvinte memorie SRAM; 

- 256k cuvinte on-board flash ROM; 
- 3 conectoare de extensie (interfaţă memorie, interfaţă pentru periferice, interfaţă pentru     
  portul gazdă - HPI – Host Port Interface); 
- controler USB JTAG cu drivere plug and play; 
- codec stereo Burr Brown PCM 3002; 
- operaţii la +5V; 
- VC5416 lucrează la 16-160 MHz. 

 

DSK 5416 este o placă multi-layer de 210x115mm, alimentată de o sursă de putere externă de 5V. 
Placa este echipată cu o interfaţă I/O externă care suportă porturi paralele I/O şi porturi serial-sincrone 
(echipate cu buffere) pe mai multe canale. Interfeţele importante ale DSK includ interfeţele pentru RAM şi 
ROM, FPGA, interfaţa pentru Codec şi interfaţa de expansiune. Patru mufe jack stereo asigură intrări şi ieşiri 
de la codec.  

DSK permite verificarea codului VC5416 la viteză maximă. Cu 64k cuvinte memorie RAM, 256k 
cuvinte memorie flash ROM, şi un codec stereo Burr Brown PCM 3002, placa reprezintă soluţia pentru o 
mulţime de probleme.  

Elementul central al plăcii este procesorul de semnal TMS320C5416 a cărui arhitectură multibus 
avansată este prezentată în continuare: 
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Figura 2. Schema bloc a procesorului de semnal TMS320C5416 

 

- arhitectură avansată multibus (3 bus-uri separate de memorie date pe 16 biţi şi unul de memorie 
program); 

- unitate aritmetică şi logică pe 40 biţi, incluzând 2 registre acumulatori pe 40 biţi şi unul de shiftare; 
- multiplicator paralel 17x17 biţi cuplat cu un sumator dedicat, pe 40 biţi, pentru operaţii de 

multiplicare/acumulare într-un singur ciclu “non-pipelined”; 
- unitate de comparare, selectare şi stocare (CSSU) pentru selecţie, adunare/comparare a operatorului 

Viterbi;  
- codificator exponential pentru a calcula o valoare exponenţială a unei valori din acumulatorul de 40 

biţi (1 ciclu); 
- două generatoare de adrese cu 8 registre auxiliare şi 2 unităţi de registre aritmetice auxiliare; 
- mod de adresare extins pentru 8M x 16biţi – spaţiu maxim de adresare pentru program extern; 
- spaţiu maxim de adresare memorie 192k x 16 biţi (64k cuv. program, 64k cuv. date, 64k cuv. I/O);   
- memorie ROM pe cip cu câteva configuraţii de memorie date/program; 
- memorie RAM pe cip cu acces dual; 
- repetarea unei instrucţiuni şi operaţii de repetare pe bloc pentru codul de program; 
- instrucţiuni de mutare blocuri de memorie - pentru o mai bună programare şi manevrare a datelor; 
- instrucţiuni cu operanzi pe cuvinte de 32 biţi; 
- instructiuni cu citiri de 2 sau 3 operanzi; 
- instructiuni aritmetice cu stocare şi încărcare paralelă şi stocare condiţionată; 
- întoarcere rapidă din întreruperi;  

1.2. Harta memoriei sistemului 
 

DSK include 64k cuvinte memorie SRAM şi 256k cuvinte flash ROM pentru încărcare. Decodarea 
memoriei externe este realizată printr-un circuit CPLD. Programul asociat acestui dispozitiv selectează 
memoria RAM, falsh ROM sau perifericele de pe placă. 
 

Memoria de date 
Spaţiul pentru memoria de date se întinde pe 64k cuvinte (2 pagini de câte 32k cuvinte). Pentru 

sistemul C5416 DSK memoria externă de date este mapată între adresele 0x8000h şi 0xFFFFh. Memoria 
DARAM (Dual Acess RAM) este mapată în spaţiul de date (între adresele 8000h şi FFFFh) dacă bitul DROM 
(bitul 3 din registrul PMST) este setat pe „1”. În caz contrar în acest spaţiu este mapată memoria externă.  
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Figura 3. Memoria de date a DSK TMS320VC5416  

 

Memoria program 
Configurarea memoriei program se poate realiza în două moduri folosind bitul 5, OVLY, al registrului 

PMST. Dacă OVLY=0, memoria RAM on–chip este adresabilă în memoria de date iar dacă OVLY=1, 
memoria RAM este mapată atât în memoria de date cât şi în memoria program, conform următoarei figuri: 
 

 
Figura 4. Memoria program a DSK TMS320VC5416 

VC5416 foloseşte circuitul CPLD (cu 8 regiştrii) pentru a selecta (interfaţa) memoria flash ROM, 
memoria SRAM, perifericele de pe placă sau pentru controlul codecului. Cei 8 regiştrii ai CPLD sunt mapaţi 
în spaţiul I/O de adrese, începând de la adresa 0x0000h până la adresa 0x0007h.  
 

Avantajele operării cu memoria on-chip ar fi: 
  - performanţa mai ridicată deoarece nu sunt necesare stări de wait 

- costuri mai mici decât cele ale memoriei externe 
- consum mai redus de putere decât memoria externă 
- posibilitatea de a accesa spaţiu de adresare mai mare 

 
1.3. Codecul PCM3002 
 

DSK foloseşte un Codec stereo PCM3002, pentru a asigura intrări şi ieşiri analogice. Interfaţarea cu 
codecul se face prin două canale, unul pentru control, iar celălalt pentru date.  

Circuitul CPLD al DSK este utilizat pentru interfaţarea cu canalul de control prin cei 2 regiştrii pe 8 
biţi în spaţiul I/O, CODEC_L şi CODEC_H, prin care se transmit comenzi pe 16 biţi codecului. 
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După trimiterea cuvântului de control, CPLD va transmite automat datele, serial, interfeţei de control a 
CODEC-ului, prin semnalele de control master. Semnalele de control serial master ale CODEC-ului sunt: 
CODEC_MC (master clock), CODEC_MD (master data) şi CODEC_ML (master load).  

În plus, CPLD generează toate semnalele de tact pentru PCM3002 printr-un oscilator de clock şi prin 
registrul de control CODEC_CLK. Valoarea implicită a ceasului sistem este de 12.288 MHz. CPLD foloseşte 
ceasul sistem al CODEC-ului pentru a genera un semnal de tact de 3.0122 MHz şi un semnal de sincronizare 
cadre de 48 kHz. Registrul CODEC_CLK permite programatorului să modifice frecvenţa de eşantionare prin 
controlul ratei de divizare a frecvenţei CODEC-ului PCM 3002. Datele sunt transmise codecului prin interfaţa 
VC5416, McBSP2. 

Un bit din registrul MISC al CPLD va permite registrului McBSP2 să fie rutat la conectorul de 
expansiune HPI; calea de bază este asigurată prin Codecul PCM3002.  
 

 
Figura 5. Interconexiunile dintre PCM3002, CPLD şi  DSP 

PCM3002- Interfaţa de control are 4 regiştrii interni pe 16 biţi care sunt controlaţi software printr-o interfaţă 
serială.  
 
Programarea interfeţei de Date 

Interfaţa de Date a PCM3002 este conectată la pinii McBSP2 ai VC5416.  
 

 
Figura 6.Codecul PCM3002 

 

PCM3002 este un codec audio cu un singur cip (convertoare analog-digitale şi digital-analogice). 
CAD şi CDA implică modulaţie delta-sigma cu rata de supraeşantionare egala cu 64. CAD include un filtru de 
decimare digital, iar CDA implică un filtru de interpolare digital pentru supraeşantionarea cu 8. CDA include 
de asemenea atenuare digitală, detectie zero infinită, şi funcţia soft mute, pentru a forma un subsistem 
complet. PCM3002 oferă un mod de putere care funcţionează cu ambele convertoare independent. 

PCM3002 este fabricat folosind un proces avansat CMOS, şi sunt disponibile într-un pachet SSOP pe 
24 de pini. Sunt potrivite pentru o gamă largă de aplicaţii, pentru care costurile sunt importante, aplicaţii 
pentru care performanţa este o prioritate.  
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Pentru PCM3002, funcţiile programabile sunt controlate prin software.  
 

Funcţii: 
 

- CAD si CDA pe 20 biţi, monolitice 
- intrare/ieşire 16/20 biţi 
- Control prin software: PCM3002 
- Funcţii speciale (PCM3002): atenuare digitală (256 paşi) 

       soft mute 
 digital loopback 
 patru formate de date audio digitale alternative 

      - Rata de eşantionare: 4 kHz până la 48 kHz 
- Alimentare la 3 V 
- Aplicaţii audio portabile/mobile 

CAD stereo CDA stereo 
- intrare pentru alimentare la un singur capăt 
- filtru antialias 
- supraeşantionare cu 64 
- performanţe ridicate: SNR: 90 dB  
 

- ieşire pentru alimentare cu un singur capăt 
- filtru trece jos analogic 
- supraeşantionare cu 64 
- performanţe ridicate: SNR: 94 dB 
 

 
Funcţiile speciale ale codecului PCM3002 sunt controlate utilizând 4 regiştrii fiecare de câte 16 biţi, vezi 
Anexa 1. 
 
1.4. Conectorii sistemului: 
 

Placa DSK are 16 conectori prin care se realizează accesul utilizatorilor la placă. Conectorii, mărimea 
acestora, funcţia fiecăruia, sunt prezentate în tabelul de mai jos, iar descrierea lor în Anexa 2. 

 
Tabelul 1. Conectorii plăcii TMS320VC5416 DSK 

 

2. Aplicaţii  
 Aplicaţiile prezentate în continuare se vor realiza folosind mediul Code Composer Studio- C5416 
Simulator. După descrierea paşilor necesari pentru a crea un nou proiect de simulare, pentru fiecare aplicaţie 
în parte se vor descrie conceptele teoretice de bază folosite. De asemenea vom prezenta formulele utilizate, 
schemele bloc ale aplicaţiilor, sursele programelor şi reprezentările grafice ale semnalelor, atât înainte cât şi 
după procesare. 
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2.1. Etapele necesare pentru a crea un nou proiect de simulare 
Procedeul următor a fost scris pentru a instala aplicaţia template, care este stocată în fişierul 

template.zip. Pentru alte proiecte, schimbaţi numele template în cel al fişierului zip folosit (de exemplu delay). 
Execuţia acestei proceduri necesită câteva minute. Este necesar programul WinZip. 
 
1. Start Code Composer Studio pentru TMS320C5416 DSK. 

2. Select Project -> New. Pentru Project Name, tastaţi cuvântul template. Click pe 
butonul Finish. Un nou proiect a fost creat. Reţineti directorul în care a fost salvat 
proiectul, apoi minimizaţi Code Composer Studio. 

3. Folosind Windows Explorer, mergeţi în directorul unde a fost salvat noul proiect, de 
exemplu C:\ti\myprojects\template  

4. Copiaţi fi şierul template.zip în directorul C:\ti\myprojects\template 

5. Extrageţi fi şierele din template.zip folosind WinZip la directorul curent cu opţiunea 
Extract Here. 

6. Intoarceti-vă la Code Composer Studio. Select Project -> Add Files to Project.  
Selectaţi calea C:\ti\myprojects\template. Folosiţi Control+click mouse stânga pentru 
a evidenţia toate fişierele .c. Click pe butonul Open pentru a le adăuga la proiect. 

7. Selectaţi Project -> Add Files to Project.  Folosind săgeata jos în Files la Type box, 
selectaţi Linker Command File (*.cmd). Folosiţi click mouse stânga pentru a 
evidenţia fişierul template.cmd. Click pe butonul Open pentru a adăuga fişierul 
template.cmd la proiect. 

8. Selectaţi Project -> Add Files to Project. Folosind săgeata jos în Files la Type box 
selectaţi Asm Source Files (*.a*, *.s). Folosiţi Control + click mouse stânga pentru a 
evidenţia fişierele .asm (dacă există).Dacă există fişiere .asm în proiect, click pe 
butonul Open pentru a adăuga fişierele .asm la proiect. Dacă nu, click pe Cancel. 

9. Nu este nevoie sa adăgam fişierele .h la proiect. Aceasta se face în mod automat. 

10. Selectaţi Project -> Add Files to Project. Mergeţi la C5400/cgtools/lib şi încărcaţi 
fişierul rts. 

11. Selectaţi Project -> Rebuild All. De data aceasta proiectul ar trebui să se construiască 
cu success şi fi şierul template.out poate fi încărcat folosind File ->Load Program. 

12. În continuare se urmează paşii descrişi în lucrarea anterioară. 

  
2.2. Controlul câştigului 
  

Controlul câştigului este implementat în proiectul numit VOLUME. Avem creată o aplicaţie care foloseşte 
opţiunile oferite de CCS [adaugă fişiere watch sau GEL] pentru a regla un câştig variabil aplicat semnalului 
de intrare. 
 Formula folosită în implementare este: y(n) = A * x(n) ; 

 
Observaţie: în cazul în care câştigul este egal cu 1, aplicaţia repetă semnalul de la intrare la ieşire. 
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Fig. 7 Schema bloc a aplicaţiei 

 
În continuare se prezintă programul sursă: 
 
/*     V O L U M E . C     */ 
 
#include <stdio.h> 
#include "volume.h" 
 

/* Declaraţii globale */ 
 

int inp_buffer[BUFSIZE];             /* procesarea bufferelor de date */ 
int out_buffer[BUFSIZE]; 
int gain = MINGAIN;                          /* variabila de control a volumului */ 
unsigned int processingLoad = BASELOAD;    /* valoarea de încărcare a rutinei de procesare */ 
/* Funcţii */ 
 

extern void load(unsigned int loadValue); 
static int processing(int *input, int *output); 
static void dataIO(void); 
 
/*programul principal      */ 
void main() 
{       int *input = &inp_buffer[0]; 
        int *output = &out_buffer[0]; 
        puts("volume example started\n");     /* afişare mesaj */ 
 

    /* buclă infinită */ 
    while(TRUE) 
    {   dataIO();     /* Citeşte datele de  intrare folosind un probe-point conectat la un fişier gazdă.*/ 
        #ifdef FILEIO 
        puts("begin processing")           /* afisare mesaj la inceputul procesarii */ 
        #endif 
        processing(input, output);            /* se aplica castigul prin functia processing */ 
    } 
} 
 
/*Functia processing:  aplica o transformare (inmultire cu un factor de castig) unui semnal primit la intrare;  
PARAMETRII: adresele buferelor de la intrare si iesire ; VALOAREA RETURNATA: TRUE.*/ 
 

static int processing(int *input, int *output) 
{   int size = BUFSIZE;         /* marimea memoriei tampon */ 
    while(size--)                     /* pentru toate esantioanele bufferului... */ 

{  *output++ = *input++ * gain;   /* se calculeaza iesirea ca fiind intrarea inmultita cu un coeficient,  
si se incrementeaza pointerele bufferelor */ 

            } 
    load(processingLoad); 
    return(TRUE); 
} 
 
/*Functia dataIO: citeste semnalul de la intrare si scrie semnalul procesat la iesire.*/ 
  

static void dataIO() 
{  return;  } 
 

/************************************************** ***************************/ 
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Aplicând un câştig de 10 vom obţine următorul rezultat: 
 

 
Fig. 8 Semnal intrare                                              Fig. 9. Semnal ieşire 

  
2.3.  Intârzierea 
 Un alt fenomen des întâlnit în procesarea semnalelor este cel al întârzierii semnalului. Aceasta poate să 
apară datorită condiţiilor nefavorabile, imperfecţiunilor canalului sau datorită diferitelor tehnici aplicate 
semnalului. 
 Formula de calcul, schema bloc şi sursa aplicaţiei sunt prezentate în continuare:   

y(n) = x (n-d); 

 
 

 
Fig. 10 Schema bloc a aplicaţiei 

 

/*     D E L A Y . C   */ 
 

#include <stdio.h> 
#include "delay.h" 
 

/* Declaratii gobale */ 
int inp_buffer[BUFSIZE];           /* procesarea buferelor de date */ 
int out_buffer[BUFSIZE]; 
int delay = MINGAIN;                         /* variabila de control a volumului */ 
 
/* Functii */ 
 

extern void load(unsigned int loadValue); 
static int processing(int *input, int *output); 
static void dataIO(void); 
 
/* programul principal */ 
void main() 
{ 
    int *input = &inp_buffer[0]; 
    int *output = &out_buffer[0]; 
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    puts("Delay example started\n");       /* afisare mesaj */ 
 
    /* bucla infinita */ 
 

    while(TRUE) 
    { 
        dataIO();       /*Citeste datele de intrare folosind un probe-point conectat la un fisier  
                          gazda. Scrie datele de iesire intr-un graf conectat printr-un probe-point.*/ 
 
        #ifdef FILEIO 
        puts("begin processing")           /* afisare mesaj la inceputul procesarii */ 
        #endif 
 
        /* se aplica intarzierea folosind functia processing */ 
        processing(input, output); 
    } 
} 

/* Functia processing:aplica o transformare (atenuare si intarziere) unui semnal  primit la intrare.   PARAMETRII: 
adresele buferelor de la intrare si iesire. VALOAREA RETURNATA: TRUE.*/ 

static int processing(int *input, int *output) 
{ 

    int size = BUFSIZE;         /* marimea memoriei tampon */ 
 

    while(size--)                               /* pentru toate esantioanele bufferului*/ 
{  if (size<(BUFSIZE-delay))     /* daca elementele cerute se afla in memorie*/ 

 
        *output = *(input-delay);                                 /* intrarea intarziata se reproduce la iesire */ 

  else 
 *output = 0;      /* altfel se transmite 0 */ 

 
 output++;                                /* se incrementeaza pointerele bufferelor */ 

input++; 
    } 
    return(TRUE); 
} 

/*Functia dataIO :citeste semnalul de la intrare si scrie semnalul procesat la iesire. PARAMETRII: nu are; VALOAREA 
RETURNATA: nu are.*/ 

 
static void dataIO() 
{ 
   return; 
} 

/************************************************** ***************************/ 
Programul folosit ne permite să fixăm variabila de întârziere. Pentru o valoare echivalentă cu 2ms 

obţinem următoarele grafice: 
 

 
Fig. 11. Semnal intrare                                              Fig. 12. Semnal ieşire 
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 2. 4. Reverberaţia 
 

 Reverberatia este persistentă sunetului într-un anumit spaţiu după ce sunetul original este înlăturat. 
Când sunetul este produs într-un spaţiu, un număr mare de ecouri se formează şi apoi scad încet, în timp ce 
sunetul este absorbit de pereţi şi de aer, creând astfel reverberaţii. Acest lucru este observat în special când 
sursa sunetului se opreşte iar reflecţiile continuă, micşorându-se în amplitudine, până când nu mai pot fi 
auzite. 
 Formula folosită în implementarea software a reverberaţiei este: 
 

y(n) = x(n-d) +1/2*x(n-2d) +1/4 * x(n-3d) + 1/8* x(n-4d) ; 
 

Exerciţiu: Plecând de la programele anterioare să se realizeze un proiect care să implementeze efectul de 
reverberaţie respectând următoarea schema bloc: 

d
x(n)

d d d 1 / 8

1 / 4

1 / 2

1

x(n-2d)

x(n-d)

+

+

+

+

+

+

y(n)

 
Fig. 13 Schema bloc a aplicaţiei 

Diagrama semnalului: 
 

 
Fig. 14. Semnal intrare                                              Fig. 15. Semnal ieşire 
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ANEXA 1 

PCM3002 – descrierea regiştrilor 

Există 4 regiştrii, iar biţii 9 şi 10 determină care registru este utilizat: 

A1 A0 Registru 
0 0 Registru 0 
0 1 Registru 1 
1 0 Registru 2 
1 1 Registru 3 

 

Registrul 0 -- DAC Attenuation Data Left Channel 
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 

res A1 A0 LDL  AL0-AL7 
 
Biţi Denumire Valoare implicită Descriere 
B15-B11 res 00000 Reservaţi 
B10 A1 0 Adresa Registrului  
B9 A0 0 Adresa Registrului 
B8 LDL  DAC Attenuation Data Load Control for Left 

Channel  
B7-B0 AL0-AL7 1111 1111 DAC Attenuation Data for Left Channel  
 
LDL ( DAC Attenuation Data Load Control for Left Channel) - bit utilizat pentru a seta simultan ieşirile 
analogice a canalului din stânga, respectiv dreapta.  

- 1 nivelul ieşirii este controlat de datele de atenuare AL (7:0)  
- 0 noile date de atenuare vor fi ignorate şi nivelul ieşirii va rămâne la nivelul anterior de atenuare.  

Observaţie: Bitul LDR din Registrul 1 are funcţii echivalente cu ale LDL. Când LDL sau LDR este setat pe 
“1”, nivelele de ieşire a canalelor dreapta şi stânga sunt controlate simultan. 
AL0-AL7  (DAC Attenuation Data for Left Channel) - nivelul de atenuare (ATT) este dat de: 

( )dB
DataATT

ATT 






⋅=
255

log20 10  

AT (7:0)   00h 01h FEh FFh 

Nivel 
atenuare 

– ∞ dB 
(Mute) 

–48.16 
dB 

–0.03 dB 0 dB 
(default) 

 

Registrul 1 - DAC Attenuation Data Right Channel 
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 

res A1 A0 LDR AR0-AR7 
 
Biţi Denumire Valoare implicită Descriere 
B15-B11 res 00000 Reservaţi 
B10 A1 0 Adresa Registrului  
B9 A0 1 Adresa Registrului 
B8 LDR  DAC Attenuation Data Load Control for Right 

Channel  
B7-B0 AR0-AR7 1111 1111 DAC Attenuation Data for Right Channel  
 

LDR (DAC Attenuation Data Load Control for Right Channel):- are aceaşi funcţie ca şi LDL 
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AR0-AR7 - DAC Attenuation Data for Right Channel 
Nivelul de atenuare (ATT) este dat de aceeaşi formulă ca şi pentru Registrul 0. 
 
Registrul 2 - Power Down and DAC Control (valoare implicită 0802h) 
1
5 

 1
1 

10 9 8 7 6 5 4 3 2 1 0 

res A
1 

A
0 

PDA
D 

BYP
S 

PDD
A 

AT
C 

IZ
D 

OU
T 

DEM
1 

DEM
0 

MU
T 

 
PDAD  (ADC Power-Down Control): 0 - modul Power Down dezactivat  

         1 - modul Power Down activat 
Acest bit setează CAD în modul de consum redus de putere. Operaţiile CAD sunt întrerupte prin oprirea 
alimentării cu curent a secţiunii CAD, DOUT fiind setat la 0, în timpul activării acestui mod.  
BYPS  (ADC High-Pass Filter Bypass Control): 0 - activat 

1 - dezactivat (Bypassed) 
PDDA (ADC POWER DOWN): 0 - modul Power-Down dezactivat  

 1 - modul Power-Down activat 
Setează CDA în modul de consum redus de putere. Operatiile CDA sunt întrerupte prin oprirea alimentării cu 
curent a secţiunii CDA, VOUT fiind legat la GND în timpul activării acestui mod.  
 
ATC  (DAC Attenuation Channel Control): 0 - Individual Channel Attenuation Data Control  

     1 - Common Channel Attenuation Data Control 
când este setat pe “1”, datele de atenuare ale Registrului 0 pot fi folosite pentru ambele canale ale CDA. În 
acest caz, datele de atenuare ale Registrului 1 sunt ignorate. 
 
IZD (DAC Infinite Zero Detection Circuit Control):  0 - detecţie zero infinit dezactivată 

       1 - detecţie zero infinit activată 
Acest bit activează circuitul de detecţie zero infinit al PCM3002: când este activ, acest circuit va deconecta 
ieşirea analogică a amplificatorului de la CAD delta-sigma dacă intrarea este zero continuu pentru 65.536 de 
cicluri consecutive ale BCKIN. 
 
OUT  (DAC Output Enable Control): 0 - ieşirile CDA active (operaţie normală) 

         1 - ieşirile CDA dezactivate  
Când sunt setate pe “1”, ieşirile sunt forţate la V CC /2 (zero bipolar). În acest caz, toţi regiştrii din PCM3002 
reţin datele curente. Când sunt setate pe “0”, ieşirile se întorc la stările programate anterior. 
DEM1/DEM0  (DAC De-emphasis Control) 

DEM1 DEM0 De-emphasis 
0 0 44.1kHz ON 
0 1 OFF (default) 
1 0 48kHz ON 
1 1 32kHz ON 3 

 

MUT  (DAC Soft Mute Control): 0 - mute dezactivat (implicit) 
 1 - mute activ 

Când este setat pe "1", atât ieşirea de pe canalul de stânga, cât şi ieşirea de pe canalul de dreapta ale CDA sunt 
puse pe mute în acelaşi timp. Acest procedeu are loc prin atenuarea datelor din filtrul digital. 
 

Registrul 3 - Audio Data Control (valoare implicită 0600h) 
15  11 10 9 8  6 5 4 3 2 1 0 

res A1 A0 res LOP res FMT1 FMT0 LRP res 
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LOP (ADC to DAC Loop-Back Control): 0 - loop-back dezactivat (default) 
   1 - loop-back activ 

Când acest bit este setat pe "1", datele audio ale CAD sunt trimise direct către CDA. Formatul datelor va fi în 
standardul I²S.  
 

FMT1/FMT0  (Audio Data Format Select) 
FMT1  FMT0  Format 

0 0 16-bit, MSB first (default), DAC R-justified, ADC L-justified 
0 1 20-bit, MSB first, DAC R-justified, ADC L-justified 
1 0 20-bit, MSB first, Left-justified 
1 1 20-bit, MSB first, I²S 

 

LRP (Polaritatea LRCIN):    - se aplică doar formatelor 0, 1 şi 2. 
       0 - canalul stânga este “H”, canalul-dreapta este “L”. 

    1 - canalul stânga este “L”, Canalul-dreapta este “H”. 
 

ANEXA 2 
 

Conectori de expansiune ai sistemului DSK TMS320C5416 
DSK TMS320VC5416 conţine trei conectori de expansiune care urmează standardele Texas Instruments:    P1 
- Conector de expansiune a memoriei 

P2 -  Conector de expansiune pentru periferice  
P3 -  Conector de expansiune HPI 

J1 - Conector pentru microfon: microfonul interacţionează cu placa PCM3002E printr-un circuit simplu op-
amp. Intrarea o reprezintă o mufă jack stereo de 3.5 mm. 
J2 - Conector Audio de intrare: este o intrare stereo. Intrarea comunică cu circuitul PCM3002E printr-un 
circuit bias op-amp. Conectorul este reprezentat de mufa jack stereo de 3.5 mm. 
J3 - Conector Audio de ieşire: este o ieşire stereo, iar comunicarea cu PCM3002E se realizează ca şi la 
conectorul J2. Este reprezentat de mufa jack de 3.5 mm. 
J4 - Conector pentru căşti/boxe: este condus de un mic amplificator TPA302 conectat la codecul plăcii, 
PCM3002E.  
J5 - Conector opţional de putere: va opera cu sursa de putere standard a calculatorului.  
J6 - Conector la +5V: puterea (5V) este adusă pe TMS320VC5416 DSK prin acest conector. Conectorul are 
un diametru exterior de 5.5 mm şi unul interior de 2.5 mm.  
J7 - Conector extern JTAG: o interfaţă cu 14 pini a TMS320VC5416 DSK şi reprezintă interfaţa standard 
folosită de emulatoarele JTAG pentru a interfaţa cu DSP-urile Texas Instruments.  
JP1 - Conector PLD de programare: acest conector interacţionează cu ALTERA CPLD, U18. Este folosit 
pentru programarea CPLD.  
J201 - Conector Universal Serial Bus (USB) incastrat JTAG: Conectorul J201 asigură o interfaţă USB 
emulatorului JTAG încastrat (situat) pe DSK. Aceasta permite dezvoltarea softului şi debugger-ului fără a 
utiliza un emulator extern.  
LED-urile: TMS 320VC5416 are patru LED-uri care pot fi definite de utilizator. Aceste LED-uri sunt 
utilizate de către POST (Power On Self Test), dar sunt disponibile pentru programele realizate de utilizator. 
Pot fi accesate prin adresa I/O 0X0000.  
LED-uri de sistem: placa are 4 LED-uri de system ce indică diferitele stări în care se află placa. 
Switch-uri: TMS320VC5416 are 2 switch-uri, unul Reset, şi un switch DIP pe 4 poziţii pentru utilizator. 
Reset Switch/Reset Logic: există 3 Reset-uri pe placă. Primul reset este „power on reset”. Acest circuit 
aşteaptă până când alimentarea este între anumite limite specificate, înainte de a alimenta pinul reset al plăcii 
TMS320VC5416. Surse externe care controlează reset-ul sunt butonul S1, şi emulatorul USB JTAG. 
Switch-ul DIP pe 4 poziţii: DSK TMS320VC5416 are un switch DIP pe 4 poziţii, pentru utilizator, S2. Este 
accesibil prin Registrul 0 CPLD la locaţia I/O 0X0000.  
 


